Laser will not move in LB but will in Grbl

I just bought a Sculpfun S30 Pro Max with the extension kit. I’m brand new at this so bear with me. Trying to learn LightBurn I used the ‘move arrows’ to get the head to move around the space. I was using 1.2.04. All was fine. Then up popped 1.3 so I downloaded that. From then on the laser would not move with the arrows no the frame button.

I moved the laser manually and clicked ‘home’ and it went home so I know the PC and laser are communicating.

I downloaded GRBL and it moved just fine.

I uninstalled 1.3 and reinstalled 1.2.04 but no change. Also, the control panel still recognized the name I gave to my laser which tells me it was not a clean uninstall; that there are still some files somewhere.

Any suggestions or ideas will be gratefully welcomed.

Thanks in advance.

Are you sure it’s not actually moving but instead just moving slowly or in small increments? Change speed in Move window and/or change move distance.

Ahhhh, thank you very much. (Told you I was new! :grin:) It was set at .39mm distance and 39mm speed. I have changed it to 20 mm distance and 3,000 mm speed. What are “normal” or traditional settings for speed and distance?

This is more about what your machine can bear and what’s practical for your needs. I believe normally this defaulted to 6000 mm/min but there is no correct speed.

And what would you say the default position would be for distance?

My preference would be for that to be a directly correlated to how you have your design setup. I generally work in millimeters. So I’d probably set that to 1mm. That would allow shift-button press to be 10mm and ctrl-button press to be .1mm so gives you a relatively good range of values.

Thank you. I will try that. Appreciate all the help today. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.