Laser will not return to origin

So suddenly my laser will not return to origin after the burn is complete.
It simply stops where it’s at.
If I click the “go to origin” button, the laser goes off in a completely different direction.

is it possible that you changed your “return to finish position” in Device settings
or you set Finish posuition in Move pannel?

“Go to Origin” sends the laser to the User Origin, not 0,0.

image

1 Like

Hi Oz,
That is my understanding as to what its supposed to do also.
Keep in mind that I never use machine 00.
I always set my work where i want it on the bed, zero the machine at the lower left corner of the work and go from there.
I do this whether I’m running the CNC or the laser.
However, I did take Otur Tech’s advise and went back through my setting.
I did in fact find a couple of setting that changed.
Why would they change? I have no reason to fiddle with the setting at all.
Anyway, I changed them, but I could not find the “return to finish position” setting.
So now I just ran another project and at the end of the burn the machine moved 4" past 0 in Y and 1.5" past 0 in X
Why would it not just go back to my user origin? (it did before)
So then I clicked the “go to origin” and it did in fact go to my origin.
Strange I tell you…

Edit Menu - Device Settings

1 Like

Sorry, there it is.
yes, thats turned on.

I do think 0x0 is relative to job origin though not machine 0x0
Maybe Oz can confirm.

If what you’re saying is true, then it’s not working. (which in my mind it should be)
The machine goes right past my job origin setting.

Would need to double check on what i say, because i am yet learning things.

Those numbers are absolute - it always flips to absolute then sends the return coordinate. It ONLY does this in User Origin or Absolute Coords modes. It cannot do this in ‘Current Position’ mode, because it has to go back to where the job started, or you would not be able to re-run a cut a second time.

I always set the origin after joging in the move tab.
my XY 0 is always on the lower left corner of the job.
Then in the laser tab, I set the start from to “user origin”
Then click the lower left corner on the job origin.
It just wont go back there after the burn.
It did at one time.
Am I missing something here?

Hi Oz,
So I re-read your post and thought I would try the “current position” setting.
Bingo,everything works as it should. (I’ve obviously had it set there before)
Now that begs the question of whats the difference between “current position” and “user origin” ??
If I set the origin of the burn then I’m the user, which in turn would be the current position.
It almost seems to me that you have to many choices.
It should be either machine X0 Y0, (absolute) or an X0 Y0 location set by the user, which would be the current position.

Our documentation is your friend. Have a look here: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

Hi Rick,
Yep, I’ve read that several times.
It still seams to me that because “works almost exactly the same as Current Position”
It’s the same and again, one to many options.
Very confusing to me.

‘Current Position’ means ‘Wherever the laser is when I click the Start button’. ‘User Origin’ means ‘Remember this location until I tell you something different.’ That means you can power off the machine, then power it up later and it will use that same starting point. Current position will not do that. With ‘User Origin’ you can move the laser head out of the way to check something, then run it again if needed, and it will go back to the right starting point, and ‘Current Position’ will not do this - they’re not the same.

The modes are taken from the way DSP controllers work, as that was the first type of hardware supported by LightBurn. If you are constantly moving your 0,0 location, you’re not going to be able to use ‘Absolute’ or ‘User Origin’.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.