Laser will not turn on

Hi Guys,
I have an Ender 5 Using the Marlin thingy. It moves around no problem. However the laser will not turn on. I can control the laser using the manual fan speed control on the printer itself. I have tried adjusting the tool index from 0-6 none work. (Not sure what that was. But I read it on someone else questions)

echo: External Reset


echo: Last Updated: 2018-11-28 | Author: (Ender-5)

echo:Compiled: Apr 26 2019

echo: Free Memory: 10077 PlannerBufferBytes: 1232

echo:TF card ok

Init power off infomation.



init valid:




“Using the Marlin thingy” - That’s a new way of wording it. :slight_smile:

I have tested LightBurn with versions of Marlin from 1.1.9 and up, but I haven’t tried 1.1.6. You would need to find out what gcode command is required to turn on / off your fan. From that I can tell you if / how you can configure LightBurn to control it.

Hey thank you for that. Not sure how to find that out. Is there away to get into the software? Or send a code manually to see what happens? Thanks again.

You can send codes through the console in LightBurn. There should be some way to save gcode from whatever software you run the printer with to see what turns the fan on now, or consult the documentation for it to see what pin the fan is connected to. I know very little about Marlin myself, and less about Ender printers - sorry.

From what I can see it’s the M106 and M107 command. I think this standard through the versions. Cheers

When I type M106 and M107 in the console. The laser will turn on and off but won’t while operating the cuts etc. really stuck now.

LightBurn itself emits M106 and M107 commands to turn on / off the laser, unless you’ve changed that in the device settings. Check there to start with. Lower-right in the image below:


You can also make a simple shape like a rectangle, and then click ‘Save GCode’ to see the code that LightBurn would send the laser. You can just type those commands into the console to see what they do, if they work, etc.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.