Laser will test fire but not while running a job

Yet another one of these.

Using an Opt Laser PLH3D-6W-XF+ running on a Shapeoko 3 XXL

We ran a test job two days ago and it all went fine. Tried yesterday to run a job for a commissioin and the laser won’t fire. Does fire when running a test pulse. Checked the wiring and that it tests fine says that wiring is sound, thouygh I went through and snugged connections anyway. I’ve searched and found no answers. Some on this forum seem like they are going to bear fruit but the thread times out and is closed after a month.

ANy thoughts appreciated. Thanks.

How are you running this test pulse? Is this a hardware button?

Are you able to turn on the laser using the Fire button in the Move window?

Yes, laser controller has a test function. it is connected to the Shapeoko controller board.

Subsequent info that we’ve already tried:
Set both max and min power the same at 60%
S-value max still at 1000
Tried on two computers
Updated one to v1.0.06 from 1.0.04
Uninstalled and reinstalled 1.0.04
Find My Laser worked on one of the machines, but the other had to be manually specified
Fire button is enabled but does not seem, to fire while framing, set up to 20% power
Other stuff will come to mind. It was a long night.

This is likely not an installation issue.

Let’s not worry about running a job or whatnot. If you can get the laser to fire from LightBurn using the Fire button then it’s just a matter of working out settings after that.

First order of business is to see if LightBurn can command the laser to fire.

You need to hold shift while you frame if you want to see the laser light. But forgot about framing for the moment. If you push the fire button in LightBurn (not the HW button), do you see any light? Put the power up to 2-3% if required. Make sure your goggles are on.

Tried lowering the travel speed from 6000 to 300, power at 100%
Got a test file used to determine power range and ran it

Here’ a link to the laser:
PLH3D-6W-Series | Series of Engraving Laser Heads (
CNC Adapter/Controller is shown at the bottom of the page.

Obtained a copy of the Opt Lasers G-code Generator, just to see if the software is an issue, but have yet to try it.

I do hold [shift] while framing. Power was set at 1% and incremented up to 20%.
Layer output switch is on. Have a air assist but have yet to use it. On/off makes no difference.

What happens when you use the Fire button in the Move window? Do you get any light produced at all? Leave framing and running a job to the side for the moment. Just need to see if LightBurn can successfully command the controller to enable the laser.

I hit the Fire button, the border turns red. Nothing happens with the laser. Hold [shift} and select Frame. Nothing happens with the laser, other than the machine traces the Frame. Didn’t know that the fire button when activated would do anything without performing a Frame.

Yes. The fire button is intended to allow you to enable the laser for focusing or other tasks.

If you’re not getting the laser to fire at all this means that somewhere the signal is not getting from your controller to the laser module.

Double check the connection cable that goes from your controller to the laser module. Make sure that there is no break in the wires and that the connectors and ports look fine.

If you have a meter, check the PWM signal coming out of your controller to see that voltage is varying in the range of 0-5V in accordance with requested power level. 0% power should correlate to 0V and 100% power to 5V. This assumes that this is 5V TTL and that you’re using the “Modulation Input 1” on the laser module. If you have a 24V system then it will be similar but between 0 and 24V.

A few sanity checks:

  1. Check GRBL configuration for $30. What is this value? S Value Max in Device settings should match this value.
  2. Is Laser mode enabled? $32=1.
  3. Confirm that your device type for the laser is configured to GRBL. Press Devices button on Laser window to confirm.

Neither of these things should prevent the laser from firing but if $30 had a very odd value then it could cause a problem.

Yes, figured that the Opt Lasers Adapter or the Shapeoko3 controller may be the issue, though haven’t checked continuity of individual conductors between the two yet. Have contacted Opt Lasers support on the issue as well.

$30 = 1000
S-Max = 1000
GRBL is selected, v1.1f, both by Find My Laser on one machine and manually on the other.

Thanks for lokking at this.

I didn’t realize there was a separate adapter board but I’ve now read through the manual. A couple of things that stick out.

  1. Have you connected the controller to pins 2 (TTL) and 4 (ground) to the controller port of the adapter?
  2. Have you both turned on (key) and armed (button) the adapter prior to pushing the fire button in LightBurn? Both the “Power” and “Armed” lights should be on at that point.
  3. When using the fire button in LightBurn do you see the “Laser” light on the adapter turn on? If not, that means it’s not receiving the signal from the controller to enable the laser.
1 Like

#1 & #2: Yes for both.
#3: Unsure, as I was focusing on the laser itself at that point. Will check tomorrow.

When Fire button is red Laser light on the adapter does not illuninate, either static or while {shift]-framing. Checked continuity of wires and are OK.

Don’t have an osilloscope handy and the multimeter available isn’t capable of dealing with PWM signals.

Going to look for a GRBL controller firmware update to see if the existing v1.1f may have been corrupted.

So for some reason the adapter doesn’t believe it’s being commanded to run.

You can still test it with the meter. You won’t be able to see any of the detail but if you check for DC voltage you will get the averaged out voltage based on the duty cycle of the PWM. So laser off will be roughly 0V and 100% power at 5V and everything scaled appropriately. If you can see that there is any variation in the voltage it’s likely working. Check voltage coming out of the controller and going into the adapter.

OK will give that a go. I did test for voltage on those lines, but had the voltmeter set to 25V range. as somewhere in the docs I saw the range may be 0v-24v. The Fire Button power was set to 20% but there was zero mevement of the needle. Did see that under 2v = “off”.

I have sent a communication to Carbide 3D about this, as I fear that some component on the controller board has failed during that first test. Either that or there is some setting that I’ve missed that is shutting the PWM output off. Will run a voltage test in the 5V range in the morning.

Also, do you know of any way to independently fire the laser throuh those existing PWM lines, bypassing the machine controller? I’d like to learn if it is the controller output or the adapter input that is faulty. Having both in the mix muddies that determination.

Did you test straight out of the controller or only the lines coming into the adapter? If coming out of the controller then not sounding good for the controller.

I’ve been trying to think of something that would cause PWM not to be generated but I can’t think of anything. But I’m not familiar with your particular board. Do you have a link to the specific board?

I can think of a handful of ways to approach this.

Here’s an extract from the adapter manual:

The adapter is quite flexible in terms of what it can expect. I’ll list options from most accurate test to least accurate.

  1. If you have access to a signal generator you could create a PWM signal and just send it directly through to Pin 2. 5V TTL at whatever duty cycle. If you have an arduino or any other board that could generate a PWM signal you could use that as well.
  2. I’ve never tried it but I suspect you could simply provide any non-zero voltage to pin 2 and it would simply be interpreted as full power. If you have a bench power supply or really any other DC power source like a battery you could try applying power to the pin.
  3. Instead of trying to do a direct test on Pin 2 you could use the analog input on Pin 1. It takes analog 0-5V with 0 V being 0% power and 5V being 100% and scaling linearly. It’s 24V tolerant so you could put basically any power source on Pin 1 and get the laser to fire. It’s not as ideal since you’re not testing PWM but would show you can control the laser through the adapter.

Quite simply, pull the pwm line high. You want to remove the controller out of the loop.

Can’t measure the pwm base frequency, but an analog meter always reads RMS value between the points. Same with the mA meters we use…

There appear to be two options. Your hardware is broke or it is not configured properly… I’d bet on configuration.

Same with $31, they define the pwm range or how % power is defined. Generally it’s zero but could be one, so the range is 0 to 1000 or 1 to 1000…

If I read in here that you can fire it via Lightburn, but it doesn’t run a job, I’d say it sounds like the hardware is ok…

Good luck


Your laser is looking for 5-10khz on the pwm input side.

Most of the arduino based stuff is 1000 hz. Without a frequency counter or an oscilloscope this will be difficult to troubleshoot or confirm.

Is there a way to verify or change the pwm frequency of the Shapeoko 3 XXL in firmware to confirm that it’s in range?

S-Value max ($30) = 1000
S-Value min ($31) = 0
Laser mode enable ($32) = 1

Can not fire via Lightburn. Only method to fire after the failure is to test fire on the Opt Laser hardware adapter itself. In Lightburn, when the Fire Button is enabled and pressed, the border turns red but it does not fire the laser, nor when holding [shift] and commanding a Frame move.

Tested the connecting cable continuity independently and then voltage when disconnected from the adapter but connected to the controller.

Moved the brown wire from pin 2 to pin 1 and applied 1.5v. Laser fired and indicator illuminated.
Moved brown wire back to pin 2, applied 1.5v. Laser fired and indicator illuminated.
Fire Button in Lightburn still does nothing, so I guess I’m looking at getting a replacement controller board.

THEN… I looked at the adapter docs pages again and found:
PLH3D-CNC Adapter Settings

When consulting the current settings of the adapter all three indicators were lit. Cycled through them until they matched the Shapeoko light pattern (only laser indicator lit) and let it save. Ran a job and it works… after a fashion, though not as before. Fire Button enabled or disabled, the laser constantly sits at some low power state, maybe 5% power or lower. The laser firing indicator never shuts off, even when the job is completed. Have to manually disarm it. Also, the definition isn’t as good as before. Nor is it as powerful. Slowed the traverse speed and upped to 100% power and not the same. With the laser always at 5% power it leaves faint scan lines between actual burns. Close, but no cigar.

Will query Opt Lasers to see if there is something else that should be set or if the Shapeoko setting is not valid for this particular machine. At least we’re getting some results.