Laser won't turn on to run file; Will turn on with Focus Test

I just installed the Lightburn demo version and have been trying to get it to work with my Shapeoko, GRBL v1.1f.

When trying to run a simple text test file, the machine runs as expected, but the laser does not fire. The laser will fire if I run the “Focus Test” command.

Also, it will not fire if I try entering G1 S## commands; M03 S## commands; Test Fire does not work;

$10 =0; $32=1; $30=1000 (matches spindle max in settings); Selected mm/min in settings;

I can exit Lightburn, start Universal GCODE and run laser with M03 command (laser is still functional).

What else should I review?

How fast are you trying to run the job? With GRBL 1.1f, LightBurn uses the M4 (variable power) command. If you tell the laser to move faster than the travel limits in the firmware allow, it will reduce the output power accordingly, so that you get a consistent level of burn.

For example, if I told my laser to run at 100mm/sec, 100% power, but it could only travel at 50mm/sec, if I left the power set to 100%, it would burn twice as dark as I intended. By reducing the power to match the reduction in speed, the output is what I asked for.

If you’re accidentally in ‘inches / sec’ speeds, or you asked for 400mm/sec on a GRBL device that can’t go nearly that fast, you might get no output. Could that be it?

I tried experimenting with various speeds, for example as slow as 20 mm/sec and as fast as 1000 mm/sec to see if that produced different outcomes, but it did not.

What is your machine limited to? (type $$ in the console and hit enter, and paste the results here)

You say the laser does fire if you run the focus test? What power % did you set for your simple text test? (IE, what were your settings for the layer? Was it a fill or line?)

I tried multiple power settings, 5% up to 100%. I tried fill, line and fill + line.

Ok, go figure… I got home from work, went to copy my GRBL settings, figured I’d try running it one more time and voila!!! We have lasers!

Thanks for the help, it was driving me nuts… I still don’t know why, as I did not change anything from yesterday, so I can’t provide any insight as to “what” might have fixed it.

I spoke too soon… Finished the test run, it went great! Tried to run it again, and I’m back to “no laser”…Tried re-starting and same issue, still won’t fire on a file or the “test fire”. It will run the Focus Test. Below are my GRBL settings


Your maximum listed speed is 500 mm/minute, or 8.666 mm/second. Did you try to run faster than that?

I have tied to run faster and slower… The file that worked about an hour ago ran a 3000 mm/min

Like I said above, your machine has firmware settings limiting it to 500 mm/minute which is 8.3mm/sec. You can change those firmware limits, or you can set your cuts to at 8.3mm/sec or less. That would get you full power.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.