LaserGRBL and LB

I am presently evaluating LB, but have encountered a problem, the solution to which has so far eluded me!
I also use LaserGRBL, and eventally discovered that setting the max. spindle speed to 0 will cause the laser to be controlled ON/OFF. Now, in LB, the laser power selection no longer works - the laser is always on full power. I’ve reset the (relevant?) GRBL values, but the problem stubbornly refuses to remain.
Any suggestions most welcome.

Setting the max spindle speed to 0 completely breaks ‘Variable Power’ mode, which is what LightBurn uses by default. If you want LightBurn to behave the same as LaserGRBL, use the “GRBL-M3” device profile in LightBurn, not “GRBL”.

That said, my suggestion would be to NOT do what you did, because you will not be able to control the laser power at all - it will simply be off, or on at 100% all the time, which is almost never what you want. You won’t be able to control the power to fire it low for focusing or aiming, for example.

So, you want the problem to come back? :wink:

Ah, it’s the old brain-fade butting in again! But the real problem appears to be that restoring the max spindle speed to 100, or 255 or even 1000 does not remove the problem in LB, and I am at a loss to see how this can be? I should have mentioned I recently upgraded to GRBL 1.1h; spindle speeds seem to be absent in 0.9 version. Also, when I have tried using LaserGRBL I could not get the laser operate at all. Using what seems to be an obscure ‘trick’ to set a maximum value to zero had the desired result, and in this situation 100% power from my 500mW weedy laser was OK.
I suspect there is more to this gerbil creature than meets the eye. I see other forum comments about changing variables in the config.h file and re-compiling, but I really don’t wish to explore that rabbit (aka gerbil) hole!

In the console, type $$ and press enter, then copy the output here. There might be other settings that are strange.

Thanks again for taking up the challenge! I should admit I’m a complete newbie to the world of laser engravers, so am at the start of the learning curve. Below is the grbl content as it is at present. Apart from the ones previously mentioned, only $100 and $101 have been changed to give the correct calibration. I think some of the values are redundant, like Z-axis stuff. On my controller Arduino Pin 11 is used for PWM laser control, but is connected to a 2-pin socket for the laser, which I think is a fudge, as the laser cooling fan should not be PWM controlled! There is an unpopulated 3-pin socket footprint with one ‘pin’ also connected to D11, which is obviously where a TTL PWM laser should be connected.

Grbl 1.1h [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
$0=10
$1=250
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=100
$31=5
$32=1
$100=80.000
$101=80.000
$102=250.000
$110=8000.000
$111=500.000
$112=500.000
$120=30.000
$121=5000.000
$122=1000.000
$130=300.000
$131=300.000
$132=100.000
ok
Any ideas?

These should likely be:
$30=1000
$31=0

And check that the ‘S-Value Max’ setting in the device settings in LightBurn is set to 1000 to match.

Thanks for setting me right. The ‘S’ value seems to be key to the problem. I shall have to look more deeply into that particular aspect of control. Now all OK.