Last ditch attempt at repair.. please help

Good morning…

I figured I’d post this here for the most responses, as I’m not sure which category it fist into…

I posted about this issue a while ago, but sadly I’ve been ill and the topic closed without result. My issue persists.

So… I have a recurring fault on my machine whereby it randomly offsets part of the design in relation to the rest. I’ll try and explain…

For example, if I cut a basic circle with a hanging hole, the machine sometimes puts the hanging hole where it should go, dead centre at the top… and sometimes it offsets it slightly thus ruining the piece.

If I have a design which is engraved, the machine will run the engraved section, and then go back to cut the shape out, but the offset cut will be in the wrong place this again ruining the piece.

Its as if the machine is breaking the design down into different parts when it engraves or cuts, like layers within a layer. When its finished one part, it starts the next but forgets its start point. It doesn’t matter if its all engraved, cut and engraved, or any combination - if there’s more than one element to the shape, they are offset incorrectly one from the other.

I’ve managed to narrow the fault down to being on my X axis, and it appears that it gets slightly worse the further away i get from the origin.
My machine start origin is the top right of the bed… so when I cut a row of identical shapes along X, the machine is moving right to left. The further left we go, the worse the fault becomes.

I’ve proved the X vs Y by running a vertical line of shapes down Y with no issue.

My immediate thought was mechanical, but I cant find a fault. I then turned to settings, but I’ve pretty much changed everything. I assumed missing steps but it seems not

Stuff I’ve done
Alignment is perfect, lens and mirrors all good, tube mount good, all the basics are ok
Checks all obvious mechanical aspects, pulleys, cogs, wheels etc and checked all screws and mountings,
Checked the belts, examined them for faults… loosened and tensioned in different ways,
Recalibrated the steps to within 0.1mm on both axis, and proved the calibration cutting set 100mm squares all over the bed,
swapped the controller for a known good one,
swapped the stepper drivers,
swapped the motors,
uploaded new known good settings to the controller,
sent my test file to someone else to run, no issues with the file,
designed it locally on the machines laptop,
uploaded via cloud,
tried the file in RD works,
none of it is helping.

I’m convinced it s a setting somewhere that’s wrong, I cant understand how I can possibly have changed all this stuff and not found the issue. I’m literally run out of ideas and considering a new machine.
Yesterday, I just drew a basic line of text with an offset border in Lightburn across X in the centre, Copied it across Y in the centre and engraved both together. You can see straight away that Y text is perfect, but in the X text, the offset border is in the wrong place.

I’ve uploaded some photos so you can see the issue. Thanks in advance for any help!

Windows 10
latest version of Lightburn
JQ Chinese blue & White 130W
Ruida controller







Mechanical sounds most likely, but it seems you’ve covered most of the bases there. You must be almost to the point where you could build a new machine out of spare parts.

The only thing that comes to mind as a possibility that you haven’t mentioned is the linear guides. Have you squirted fresh lithium grease into them at any stage? I’m wondering if they bind occasionally.

The other thing I notice is that the problem seems to occur between layers, which leads me to suspect rapid transits. Is it possible that the acceleration is too high and you’re skipping steps there?

1 Like

Following the rapid transit idea, can you post a screenshot of the preview window for the text test? It would be interesting to see where the head is moving between cuts.

1 Like

How is the file sent/transferred to the machine? When I was using USB cable, I had similar problems, mostly missing segments but also shifted segments. Using a flash drive was one solution, but having the machine connected to my home network (wired) also removed such problems.

1 Like

This document talks about skewed engraving. I would check the PWM rising in the machine settings.

1 Like

So interestingly… I altered the PWM rising value setting on X, and it cured the offset issue on the basic text example picture I posted. I figure that’s just my fault not setting it up properly following the different motor install. Its not cured the fault however… I’m replying to all the messages so you’ll see as I go along… but good call thankyou

1 Like

That is not something I’d considered. I’m using a USB cable from the laptop straight into the controller. I will try a different cable, or a flash drive tomorrow… I’d not thought of that!

you’re not wrong :roll_eyes:

Guides are squeaky clean and running beautifully… bearings all good… about the best thing on the whole machine :joy:

I’m pretty sure I lowered the acceleration during testing, but I’ll check again. The machines 130w with Nema34 motors in it… it should be able to handle it. And its a developed fault, its been running great for years

Annoyingly I deleted it… so if I recreated it, it wouldn’t count. I’ve done some more testing so see the updates…

So thanks for all the replies here…

I’ve done a bit more testing today. The rising PWM change certainly altered the offset bubble on the text and cured it, however as I said before I’m pretty sure that was just a set up issue.

I ran a sheet of designs earlier…
3mm mdf
.dxf file broken into two layers, first to engrave and then to cut out
designed in Vcarve
sent via Dropbox to the machines laptop
laptop to machine via USB


this is the image of the whole sheet. As you can see the some is engraved. My origin is top right.


Heres the path image

Far left monkey screen image
here’s a close up of the monkey design on the far left…


Here’s the whole sheet… I stopped it short of finishing since it was wrong anyway


Here’s the far left monkey. Orientated correctly on the sheet. Look at the engraved parts where they meet the cut


And finally… this is the same monkey, from the same file, the same design… just isolated as one image from the rest of the sheet. I put the start point on the bed far over to the left, roughly where the original nested monkey would have been, and then ran it as an individual design. Came out fine.

I am utterly clueless.

If you didn’t modify it, it won’t change itself…

IMHO, this leads many to complicate the problem by modifying things that are easy to get to… however logic suggests you look elsewhere. Two years worth of running would indicate more of some mechanical issue rather than a configuration problem…

Lots of mechanical idiosyncrasies have some hard to find issue, such as a ‘grub’ screw in some obscure hard to get at place, backing out or creating a slot to move a slight amount… Hard to find and identify.

The controller (at least dsp) and drivers have ‘error’ indicators on them…

gOOd Luck

:smile_cat:

1 Like