Latest upgrade issues

There is a huge issue using LB on a new yora silverback. The x left and x right jog buttons move in the same direction. The y jog buttons do the same. Z is ok. Yorahome says the problem is lightburns and this problem started a few revs back. I mentioned this in an earlier post and it was never answered. Why would I purchase a software that doesnt work?

Do you know which version of LightBurn broke the jogging for YoraHome machines?

Is that the “YoraHome SilverBack Benchtop CNC Router 6060”?

Try this please:

Immediately after homing, enter these commands into the console (one line at a time)

G92X0Y0
$10=0

Then try jogging again, any difference?

Same results. Both left and right buttons produce the same direction. Lasergrbl works fine and so does easel.

Does that machine home to the front left?

Re-home the machine, then while still in home position enter these commands, one line at a time;

$i
$$
$#
?

Use your mouse to copy the results from the console window and paste back here please.

1 Like

I think i found the issue. I uninstalled, deleted .ini and reinstalled. The jog buttons worked correctley until i changed the jog distance to 1mm. It works fine with 2 etc. Thanks for your quick response and im off to try my first burn.

I am finding out that I do need to move z in 1mm to adjust focal point. How can i accomplish this if the machine as setup will not respond properly to 1mm jog distance. The z does not move at all with distance setting of 1mm. Is there another parameter i can change? I am using a phone so thats why I cant easily send you the info you requested. Thanks

Problem solved by installing older version of software. I think its a shame that lightburn would not admit there latest software has issues.

I am not sure where you are getting this impression. I know personally, I say all the time, “This is software, and things come up…”.

While we extensively test each release internally, and with our public Beta Group members, this is software. Things come up. We know this, and make significant effort to scrub “issues” from the code, prior to release. When an issue arises after we have released to the public, we work diligently to learn, resolve and prepare a patch or update and make that available as soon as possible.

You said this, but the only evidence of an issue you’ve offered is that the older version works.

I’d love to figure out why it’s broken and fix it, but I don’t have one of those machines.

Can you tell me which version of LightBurn you installed that is working?

If you had answered Nicholas’ question about the results of those console commands we might have been able to diagnose and fix the problem. If you’d prefer not to answer, we’ll have to wait until we find someone who will, or wait for one of those machines.

LightBurn’s jogging commands, by default, try very hard to keep you within the bounds of your machine. If the machine isn’t homed properly, or using negative workspace, that can cause issues.

Thanks for your reply. 1.2.04 works. If you read all my correspondance you would have seen that i said the jog buttons worked with a setting of 2mm or greater. It was when I set it at 1mm distance when it crapped out. I also stated that I was using a phone for this forum so I couldnt easily cut and past parameters. I could not get my machine laptop to go to your website because my anti virus software flagged your site as having an old or expired certificate. I will get you those settings to you so others may be helped. Thanks Dave

Hi, I just upgraded to 1.3.01 and it works fine. Did I originally have a corrupt file? Now I feel like an idiot. Lol

It was very likely a setting you had incorrect, which is what Nicholas was trying to figure out by having you type those commands.

1 Like