Latest version of Lightburn not working

Since updating software to 1.1.04 I have had nothing but issues.
I’m using
Windows 10 Laptop
X-Carve with X Controller
Opt PLH3D-6W
Grbl version 1.1g

Heres my GRBL settings

I have replaced all cables
Everytime I open new Lightburn, nothing is saved. None of my prefs, none of my macros.
If I start a job, it quits after a minute in the same spot each time.
Occassionally this weird symbols will appear in my console window (black diamonds with ‘?’ in them)
Laser will constantly be busy even though its not and Ill have to quit program (input all prefs again) and start of. Its beginning to make me want to stop using it.
Nothing has changed since updating Lightburn. Ive tried rolling back but this doesnt help either.
Please Help. Its getting desperate.
I can upload screeshots if neccessary its just so frustrating now as Ive go literally nowhere in over a week and it was fine before updating

it seems to be a cable issue, have you tryed to change USB cable? or even USB port?

Thank you so much for the reply!
Yes! Ive replaced cables.
I use a program for my CNC work called CNCjs. This works perfectly fine. Its just since the update of Lightburn that im having Light burn problems.
Even Homing the machine leaves it hanging and I have to reboot.

Well, in this case is better wait for @Rick from staff

Thanks again. Hopefully soon! I did a post the other day and I’m getting a bit desperate now.

Are you absolutely certain the symptoms are the result of the version upgrade? Some of the behaviors are odd. I suggest you downgrade to the previous version to confirm, especially if you’re stuck in the water.

Releases · LightBurnSoftware/deployment · GitHub

Yes 100% sure. No issues with Lightburn until upgrade. I have tried rolled back and this didn’t fix it either. I’m really stumped.

If the downgrade didn’t fix it I suspect there’s something else going on in spite of the timing of the issues.

While rarely the right thing to do you may want to try clean slating the install by deleting the contents of the prefs folder. That means you’d have to reconfigure your laser. You could simply move the contents of the prefs folder to a different location to keep as a backup.

Are you by chance hosting LIghtBurn or the Prefs folder on a cloud synced drive or network share drive? I’m especially concerned with your mention that things are not getting saved.

If not for those issues I would suspect the issues being a failure in the controller. Instead I’m wondering if you’re experiencing an issue with the computer. However, your mention of CNCjs working makes me question that. And to confirm, the CNC machine you’re connecting there is the same machine being used for LightBurn?

I did the clean install too. Even run an Uninstaller program after to remove any residual files. I have done this twice (for when I rolled back too)
All files are coming from the C: Drive of my PC although the projects are stored on an external hard drive.
All other aspects of the XCarve work fine just Lightburn.
With CNCjs I can move the machine in x y and z with no issues. With Lightburn if I press move it’ll hang the entire machine.

I really appreciate the feedback and suggestions but this has really got me frustrated as I’ve done literally everything (including replacing cables)

How exactly did you do this? Did you make sure to remove the contents of the folder opened with File->Open prefs folder?

If so, this doesn’t seem like it would be a LightBurn issue. There’s clearly something else going on at an OS level.

External hard drive is plugged in directly to the computer or it’s a network drive?

Can you open Device Manager and check that there’s only one port defined for the machine? It’s odd that you’re getting such different behavior from LB vs XCarve.

Can you confirm that you’ve configured the Laser as a GRBL device? Push Devices button and click on the name of your laser one time. It should list the controller at the bottom of that window.

Can you take a screenshot of Edit->Device Settings? Curious if there might be something there.

Thanks for all the suggestions. I’ll try the uninstall again tomorrow.
Projects are on hard disc plugged directly into 1 of 3 USB ports (mouse and xcarve in others)
It’s been working perfectly since I built the machine. All of this has happened since I upgraded.
I’ll provide screenshots asap. Thank you again for your time. It’s much appreciated.

So this morning…

Checked all drivers are up to date….

Checked for any windows updates.

Complete Uninstalled Lightburn (including prefs folder. The iObit Uninstaller I used does this automatically, but I checked anyhoo)

Reinstalled Lightburn v 1.1.04 (Windows 64-bit Version)

Redone my Device settings only this time toggled the DST setting at the request of another user who said this might help.

Pressed HOME to home laser on lightburn

Machine went through homing sequence then locked up

Quit the program and none of my preferenes were saved, also no says

Waiting for connection…

Port failed to open - already in use?

I’m beginning to think it’s really broken.

Literally nothing has changed from my end. I’ve bought new cables. The machine still carves and has only run into issues since this Lightburn update. It’s getting to the point where I’m not enjoying this and am considering looking for alternatives for laser software.

I don’t think this is an issue with LightBurn as the symptoms are not consistent with typical LightBurn problems. Based on your description I suspect there’s something going on at the OS level.

Do you have any antivirus or active monitoring applications running? Something that could potentially affect a running application.

Have there been recent OS updates, new applications installed, or anything similar?

Do you have another computer you have access to that you could use to test if you can get LB connectivity to the laser? This would help isolate root cause.

I’m not 100% certain but you may be able to run Windows in Safe mode to see if behavior changes. I can’t recall if Safe mode allows USB-Serial devices to be used.

If you go to File->Load Prefs Backup do you see a list of backups? That would indicate if there’s even an attempt at saving these files.

No antivirus running, only windows defender. Nothing new installed.There are backups in preferences. Since update, it seems to ignore these and each run is a brand new run. Its so frustrating. My CNCjs work fine still and I can control my XCarve axis perfectly with this. The second I press anything on lightburn, it just hangs saying laser is 100% busy. I could scream :weary:
Thanks so much for your time and effort though. Im beginning to feel like giving up tbh ive been at it again for another full day.

Is it possible this is running in background and contending with the port? Or any other similar program?

Do you have a Windows restore point from shortly before issues started showing that you could revert to?

Nothing else is running at all. Each time Lightburn locks my Xcarve up, I have to reboot the PC anyway.

One thing I noticed which is odd (dont know if it helps at all),
Ive rebooted PC
Powered on Xcarve
Started Lightburn
I can move carriage around like normal.
The moment i press home it hangs and i have to repeat these steps.

If you can, try running in Safe mode. Short of trying with a different computer or reloading your OS that’s probably the most isolation you’ll be able to get easily.

Just added to my reply above

You could try changing baud rate and/or transfer mode to see if that affects connection reliability. Do you know what your settings on CNCjs are for connection?

I’m not aware if your machine requires DTR or not. If not required I think it’s preferable not to have it.

The baud rate is 115200 for CNCjs

I started Windows in Safe mode. Unfortunately none of the USB connections were recognised so it wouldn’t connect to Lightburn.

I tried both Safe and Safe with Networking.

Just started Lightburn and in console window typed


To see GRBL

This has hung Lightburn and is saying Lightburn is 100% busy.

This version of Lightburn is too broken for me, I think I’m giving up for today. Thank you so much for your time though. Its really appreciated.

I agree, it wasnt on before so ive turned it off.