LB Hangs Finding Laser

Successful LB user for past 6 months, no issues. Upgraded PC to be more capable with Fusion360.

  • Deactivated license on old PC
  • Installed 1.1.01 on new PC
  • Activate license, success
  • Same USB cables
  • VCP drivers show COM3 port that comes and goes as laser is powered on/off
  • Find My Laser - HANGS, have to kill the process, no joy finding laser

I’m stumped… could be something with new install of Win10 I missed? Loose nut behind the wheel is far more likely explanation.

Red/Black 700x500 80W
Rudia 6442S
Lightburn 1.1.01, tried 1.1.02 as well
i9-9900k, 64G memory; upgraded from i7-7700, 16G memory


Anyone?? Tried again today

Would still like to understand what’s happening here. As a workaround (?) I manually configured the controller using LAN connection, it works fine; never had to use LAN in past

I think you need the FTDI driver. I believe you can get it from the RDworks package that came with your laser or search around here using the model number for your controller.

Please respond back and let me know if you find it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.