LB realtime Adjust Speed and Power not working

While conducting some machine testing and attempting to adjust speed or power realtime while cutting a straight line, neither of the control sets (in the cutting realtime Move window) to decrease speed or power are having an effect on my machine. Also I don’t see the realtime grbl commands being issued in the console (Show All on) which implement this grbl feature. I have tried 2 straight line designs, one being a single line segment 800mm long, the other being 30mm lines strung together is a flattened array.

Win11, grbl1.1i, GRBL device type, LB v1.4.01
Is there an LB or grbl config specific to this function ?

@LightBurn Here are my grbl config settings, and the grbl realtime feedrate and spindle speed commands which don’t seem to be working in LB in my case. However, using another gcode sender connected to my machine, the realtime commands do take effect as they should. I suspect this means the grbl config is ok?
Please advise on what could be the LB issue.
thanks.

$I
[VER:1.1i MR MegaV bLouChip Tri-CAM Open Frame Bed.V4-20230807:]
[AXS:4:XYZA]
[OPT:VNMPHRL,35,255]
ok
$$
$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 6 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 0 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 1 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 1 (Homing direction invert, mask)
$24 = 50.000 (Homing locate feed rate, mm/min)
$25 = 1000.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 5.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 1 (Laser-mode enable, boolean)
$100 = 57.288 (X-axis travel resolution, step/mm)
$101 = 57.288 (Y-axis travel resolution, step/mm)
$102 = 200.000 (Z-axis travel resolution, step/mm)
$103 = 13.333
$110 = 16000.000 (X-axis maximum rate, mm/min)
$111 = 16000.000 (Y-axis maximum rate, mm/min)
$112 = 4000.000 (Z-axis maximum rate, mm/min)
$113 = 15000.000
$120 = 1450.000 (X-axis acceleration, mm/sec^2)
$121 = 1450.000 (Y-axis acceleration, mm/sec^2)
$122 = 700.000 (Z-axis acceleration, mm/sec^2)
$123 = 4000.000
$130 = 891.000 (X-axis maximum travel, millimeters)
$131 = 791.000 (Y-axis maximum travel, millimeters)
$132 = 88.000 (Z-axis maximum travel, millimeters)
$133 = 2160.000
ok
$G
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]
ok
0x92 This is feedrate decrease 10% realtime command
0x91 feedrate increase 10%
0x9b spindle decrease 10%
0x9a spindle increase 10%

standby, I may have found the problem.
I was using LB setting Transfer Mode: Synchonous . I’m in the office now on another grbl board (no CNC, just grbl), and when I changed the Transfer Mode to Buffered’ the ‘cutting’ time of the line segment got much longer. Still no realtime commands appearing in the console (show all), but thats not the problem, as long as the command effect is occurring. I’ll go out to the shop and confirm the same behavior on the real CNC machine.

confirmed. LB Transfer Mode must be Buffered on GRBL device in order for realtime Adjust Speed and Power to work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.