Lead in Lines Not Showing in Preview

I’ve been using lightburn for three days and I’m stuck. I am struggling to get lead in lines to work. I have turned it on under ‘cut,’ set the start points, I have told it what direction to go in. When I go to preview, they don’t show up. They don’t happen when I run the job, either. What am I missing?

If you share the file, we can take a look and offer some suggestions. :slight_smile:

Below I show 2 rectangles with 10mm arc lead-ins @ 45º. I added a node and made that the ‘Start from’ node.

That might be the answer. How do you add a node outside of the shape? If I could add a node outside of the shape, I could make that the start point. Screenshots below.

Screenshot 2021-07-27 12.05.08
Screenshot 2021-07-27 12.01.37

Sorry, but I do not understand what you are asking here. Nodes are not inside or outside, they are “on” a shape path. To add or ‘Insert’ a node, in ‘Edit Nodes’ mode, hover on the path and then press ‘I’ for insert. Node Editing - LightBurn Software Documentation

Then you can change the ‘Start point’ using

.

Also notice you have a very short Lead-in set. Hard to see without zooming in a bunch to see in Preview. I set the same to show both no zoom and then zoomed in to see the short lead-in.

-

How do I add a node outside of the shape and connect it to the shape to make the lead in line? Or do I have to do that? Will it construct the lead in line on its own if I just pick a node and tell it to start there?

Yes, in most cases. I added the node mid-way on the long path segment to provide room for LightBurn to generate the Lead-in for you. I wanted to have the Lead-in start point begin from the inside of the shape. Placing where I did, tell LightBurn to start inside the shape, so you don’t cut through the desired resulting shape.

I’ve got the outside shape right now. Thank you! Any advice on the inside shape? No matter what I use, lead in or lead out, a negative or positive number, I can’t get it to be inside the center circle instead of outside.

Screenshot 2021-07-27 15.20.24
Screenshot 2021-07-27 15.19.34

Is your shape a closed path? Hard to tell from what you are showing. Below, I assume a closed shape. I set ‘Cut inner shapes first’ in ‘Optimization Settings’, and set the Start point as indicated by the blue arrows on path.

-

LightBurn sorts out what shapes are “inside” another and should adjust the lead-in cut to start inside that shape accordingly.

To get a lead line inside the circle, you’ll have to make sure the lead length is short enough to actually fit within that circle.

This is an 8mm lead-in, on a series of different sized circles. The left-most circle is only 5mm in diameter, so an 8mm lead in line, at 90 degrees, just doesn’t fit.

image

1 Like

The line length was .01mm too long. Reducing it fixed that problem. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.