Lead-In/Outs location on Outside Shapes?

So, today I had this Measurement Template done to confirm the locations of my Voron V2.4’s Z-Axis Belts before making a new precision cut Top Panel omitting the 3D Printed Corner Pieces.

While for the Template of no relevance I’ve noticed there being somewhat of an issue with how some of Lead-Ins/Outs were done - Basically the two Circles inside the Template used for handling the Template were done properly with the Lead-Ins and Outs situated inside the part that would be discarded but for the outer Shape they ALSO happened to be inside instead of the outside which isn’t exactly what I had in mind :thinking:

The Entire Project

The Cut Setting

The Entire Preview

Detail of Internal Cut :white_check_mark:

Detail of External Cut :x:

The Project File:
Panel.lbrn2 (27.5 KB)

Any idea what is going on with the External Lead-Ins/Outs and how to solve their wrong Orientation for when they’re actually needed? :face_with_raised_eyebrow:

This happens when the start position does not have the necessary clearance for the lead-in/out. Personally I’d like to see LightBurn attempt to only use valid entry/exit points or else warn that it can’t be done without material intrusion.

Easiest way to address this in your situation is to do one of the following:

  1. Make sure “Choose corners, if possible” is enabled in Optimization Settings
  2. Manually set the Set Shape Start Point of the outer piece.
    image

Toggling Choose corners, if possible seems to have solved the issue.
But how does one use the Set Shape Start Point feature? :face_with_raised_eyebrow:
I’d kinda expect a marker to appear near a selected line indicating for something to have happened / the selection being confirmed but nothing is happening? I tried both with and without selecting the shape first :thinking:

Hover over the tool and it will give you a brief explanation. But basically you can choose the node from which the cut will start. Click that node to select it. Note that optimizations can override manually selected start positions so disable optimizations if you want perfect control of that.

An arrow will appear at the node start indicating position and direction. The shape cannot be grouped for this to work so ungroup until you get to individual shapes.

1 Like

That worked!
Thanks a lot =)