Light burn always sending old job

Hi. Whenever I set up a burn in Lightburn (v1.3.01, trial license), no matter what image I have in the current job, it keeps wanting to run the first Lightburn file I tried to burn. Where on disc can I go and flush old cached job files or in-queue/pending jobs. I see no options to do so in any of the menu entries. I’m convinced it’s just an incomplete job that’s still in some file queue.

Thoughts?

You need to tell us the steps you’re taking that ends up with this failure.

I’ve been using lightburn for a while and no issues, so I wonder if it’s something in your procedure.

Lightburn doesn’t cache ‘old’ jobs to my knowledge… It does create a backup file that helps you recover, if you need to.

The software generates the control codes to your machine with what’s in the current project, it doesn’t keep any of the generated code unless you tell it to…


The trial and licensed versions are the same …

Walk us through your procedure and we can probably help you iron this out.

:smile_cat:

In the simplest example: file → new, file → import (pick a file), do nothing else except go to the laser window and hit start. The selected picture is not what the unit burns. It burns the first job I ever started, which was a small graphic I had lying around. Powering off and disconnecting the laser, killing and restarting light burn, and despite not really doing anything extra that killing Lightburn would do in this case, even rebooting the computer did not change the outcome.

Where can I find (to clean up and delete) those backup files because I assume that’s what’s being sent to the laser. So it seems.

The software generates the control codes to your machine with what’s in the current project, it doesn’t keep any of the generated code unless you tell it to…

I hear you. That’s not what’s happening, or it’s happening in a queue that is never getting flushed.

I’m a computer software developer by trade, so I can speak coherently in this context.

As a follow up - this doesn’t happen with the software that comes with the laser. I don’t want to use it as it’s pretty rudimentary and unrefined. :\

Is there a SD card in the laser? If so, maybe take that out and try.

It doesn’t (at least not that I can visually find, nor is one listed in the description and specs). It’s a Neje 3 that I picked up pretty cheaply to laser engrave/etch wooden business cards for my woodworking shop and for medallions to put on the furniture I make. Like I said, the Neje software works and sends the currently-loaded image, but is just painfully unrefined. Whatever is going on, seems to be Lightburn holding on to old work files.

Try a couple of tests:

  1. instead of an image, try burning a simple square or other shape. Do you get the same results?
  2. Enable “Show all” in Console and run a couple of small simple files. Is the output shown in Console the same for both runs?

hmm… Interesting. I added a plain square to a new job in LB, and ran it, it worked. Imported the image I wanted to run, it’s burning now (and is not the old/original job from before), and once this is done, I’ll try a separate issue. Thank you. It ** seems ** that’s resolved, but I’ll report back after trying the second image after this completes. Again, thanks much. Hadn’t thought of just trying a simple, in-app vector burn.

Nice. I’m curious about what was going on. Note that the symptoms you described are not at all common. The only times I’ve seen that were directly related to caching on an SD card outside of LightBurn.

1 Like

About to kick off the second image job, and if it works I’m declaring 1) this resolve, and 2) you, a genius. :slight_smile:

Second image job is working properly. So weird. Thank you. Go tell everyone around you you’ve been declared a genius. 'Cause you have :slight_smile: Seriously, thanks. That was a great suggestion, and my guess is it flushed out a wonky mess. I’m not reloading the original graphic I tried again, just in case. It was like a thrice or more converted EPS->BMP->PNG file so there’s a really good chance it was just a wonky file. :+1:

Ah… yes, the “try something else until it works” genius is little understood. :rofl:

Anyway, glad victory has been declared.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.