LightBurn 0.9.00 released

Rob, thanks for the stack trace info - I’ve found the cause of the crash and corrected it, and will post a patch very shortly. This will only affect users of Smoothieware.

1 Like

A fix for the Smoothieware Device Settings crash is posted. Just download from the trial page again and install over the version you have. I haven’t changed the version number, but the build date shown in the About page will be from today (March 20th).


Ok, one last time for the Smoothieware users - I have tested the Find my Laser, Device Settings, and connection, and everything looks good again. Apologies for this, but the builds have been updated again.

1 Like

Ty so much lightburn will install tommorow again and will llet you know

Regards rob

Hey Guys, really love the update and really, the software works very well. I just want to point out that in Linux, the “network error occurred: error creating SSL context ()” problem is back. It showed up on the earlier version of LB after a Linux update. Additionally LB still crashes when trying to use the camera. This was previously reported on the earlier version of LB as well. Neither are deal breakers for me as I use the software daily with no other issues, but the camera would be handy.
Ubuntu-Mate 18.04.2 Kernel

I think the code expects a very particular version of LibSSL, so if you updated that, it could well be the issue.

Agreed, Last time it was fixed I think you guys updated your Linux system but I’m not sure.

after upgrade from 0.8.something to 0.9.0, my greyscale (png) images appear reversed. Is anyone else seeing this?

Just did the update. I seem to have LOST all my settings in the cut library! :frowning:

Strange that I thought it was saved as “default” because I’ve opened and closed Lightburn many times since I set those and the library was there. But it seems there is not a .clb file in any folder I can find. Guess I lost all those settings?

You likely have “negative image” toggled in your cut setting.

You shouldn’t have lost those settings - LightBurn would never delete that file, but it might not be loaded. Older versions of LightBurn on some systems didn’t enforce the .clb extension, so it might just be called “Library” or whatever you named it.

Nope, and toggling it on “appears” to fix the problem, except now the black square doesn’t print at all (because reversing it makes it white?)

Sigh. I really need to get a much larger testing pool going again. At one point LightBurn had about 50 users who would hammer on betas, but now they’ve mostly moved along and things like this slip through. It only appears to affect grayscale, and should be a simple fix.

1 Like

I am a software engineer by trade, and would gladly volunteer to be a beta tester if you are interested. I do love the laser burn interface, and am otherwise very happy with the software.

One little note, is that I was attempting to dial in the grey scale settings for my laser with the previous version (0.8.06), and it wasn’t respecting the minimum power value (it was respecting the max). That’s why I upgraded, and saw this new behavior. I didn’t check to see if the minimum power issue was addressed with 0.9.0.

Don’t get discouraged, light burn is overall fantastic. I’ve built two lasers engravers and tried many other software packages before deciding this was the best one for me.

I’ve posted a patch release, 0.9.01 that has the Smoothieware connection fix, negated grayscale fix, and a small bug that made the window size wander a little every time you restored. It’s live.


Just wanted to say a BIG THANKS for DXF export and all of the changes/fixes you did to SVG export has allowed me to finally export SVG too!! So now I can at least use Lightburn for composition, and then export for cutting in AutoLaser - Much nicer workflow while I wait for TopWisdom supper… Thanks!!!


1 Like

Why not do public betas? Do you have a bug tracker set up?

must say the response time to fix reported bugs is outstanding.

It will always be a case of a few wrinkles to iron out during software devolepment, but this new release to fix all reported issues so quickly is superb. The dwell time has also been fixed and now shows correct.

I was contemplating between purchasing Lightburn and another well known laser software. This response to bugs, author interaction, and the pure ease of using the programme as a laser novice, means I will be paying for the full version. It’s head and shoulders above the rest I have tried. Thanks go to Oz.

1 Like

I’d gladly volunteer as a beta tester… sign me up please!

Hi there.
Tnx for the release. Installed and working perfect. Amazing software.
Where can I find a ‘new release features’ for this new release?