Lightburn 0.9.23 Bug

After the update on 0.9.23 its not possible for me to encrave objects any more. e.g. you are encraving a simple ring, you have a gap after line no. 100. After the next 70 or 80 lines the job is stopped with following message…

“Starting stream
Layer 100
Numeric value format is not valid or missing an expected value.
On or near line 425:
Job halted
Stream completed in 0:15”

I got back to 0.9.22 and its working fine. Update to 0.9.23 and its not working.
Im using Win10 with a modded K40 Frickler, SBase 1.3 and GRBL.

1 Like

No reply? Same problem exists also in 0.9.24. I can deliver you any information you want to help you solving this issue. But this bug is really really bad. I know 5 more persons having the same behaviour!

I have the same problem, with grbl lpc i had to return to 9.21

LightBurn devs are very busy right now as you can guess since the v0.9.23 update did not go as smoothly as anticipated.

Best help you can be is to see if there’s anything which pins the bug you are seeing to a setting or something. ie, if you can copy or export your existing settings file, create a clean slate and install LightBurn v0.9.24 and reproduce the issue or issues you found and post back. Most people having problems have been with Ruida controllers so seeing you’re running GRBL is an important data point.

I just tried this on my little Ortur Laser Master next to me since it’s running GRBL also and could not reproduce your problem. I tried with my existing preferrences file and with an empty preferences setup just importing my Ortur device config and changing the default units to mm/s and turning the fire button back on. ie I did’t change anything settings but those two and got a decent circle.

I made the circle within Ortur using the circle drawing tool and then the offset tool to make a 3mm wide circle. I do see a gap in the design when I let it do “Flood Fill” as opposed to when I turn that off. Maybe you can try turning off flood fill in your layer setting on the Advanced tab?

The one by itself with the wiggles was from me having speed too fast and the whole wooden table my machine is on was swaying back and forth. It’s done with 0.9.24 along with the 2nd from the top where I slowed the speed down and rotated the scanning direction back to 0 deg. Others are from v0.9.21 and then back to 0.9.24 with clean slate config.

There’s also 4 different GRBL devices to select from so I would first make sure you have tried any or all which might apply to your device. There is also a new DTR setting in Edit-Device settings which was added because of some communications issues with different micro-controllers so you might try toggling that setting and experimenting.

The Ortur Laser Master has a STM32 chip running a custom GRBL32 version 1.1f and so far it’s worked with the DTR value enabled.

just did a clean install all setting were remove, and i still have the same problem with 9.24 with and wthout DTR no differences i get that in the console Starting stream
Layer C00
Layer C00
Layer C00
Layer C00

and laser stop

@mindstorm88 so this is a K40 with a MKS-Base controller running GRBL-LPC which works with older versions of LightBurn but not v0.9.24?

Also, what is the computer operating system you are running?

exactely mks sbase 1.3 , it works with 9.22 and older for the last year, os is win10 pro

can you install LightBurn v0.9.22 and verify it will still work with that version?

already did, my last post was with 0.9.22 reinstalled.

1 Like

ok, since you didn’t start your own thread and the OP seems to be AWOL, I’ll ping the support guys to see if they have ideas on what could be causing your problems. @Rick
Windows 10, GRBL-LPC on an MKS-Sbase controller in a CO2 laser and problem gone with v0.9.22 and problem exists with v0.9.24. Problem no directly stated but for “I have the same problem” which seems to be it runs for a little while and then quits.

Any data i can give you guys, to help ??

Please review these and update when you can. Is this what you are experiencing?

Ok, here my latest try, i created a very small project with 9.22 cut it and save it. Installed 9.24 and loaded that file. In buffered mode it start but after few cut it freeze (does not mather if i recreate the file with 9.24)

After that i put it in sychro instead off buffered, and was able to do the complete project.

This issue is specific to GRBL-LPC users, and was found / fixed just today.

1 Like

Great, any time frame for the patch ? your good guys !!!

This is a link to the test build for 64 bit Windows:

Give it a try and let me know if you’re seeing any other issues with it.

1 Like

Just tried it with same project, buffered with DTR enable, and was able to do it twice without problems !! :+1: will test it more tomorrow, thanks a lot !!!

1 Like

Thx for your test build. I will also try it this day!