Lightburn 1.2.04 Unable to reset

Hello, my grbl control board has added a serial port download circuit,the schematic diagram is as follows(mcu is stm32f103c8t6):

After lightburn version 1.2.04 is connected to the control board,I press the reset button to no effect.But version 1.0.6 works well.I wonder if this is caused by setting a property of the serial port after the connection of version 1.2.04.

I need help. Look forward to receiving your team’s reply!

I don’t understand what you mean by “press the reset button”. Do you mean on the physical device?

It’s connected to the DTR line on the chip. Check if you have the DTR setting enabled in LightBurn’s device settings, maybe?

And please, don’t tag me on a random thread that has nothing to do with your post just because you saw me reply there. Tag me on your post or better still, email support@lightburnsoftware.com

Hello!

Result button is in my control board.The schematic diagram is as follows:
image

The Rst signal is connected to the reset pin of the mcu.I have disabled DTR settings.I mean that when I press the reset button, the microcontroller cannot reset normally.

When I disconnect the serial port from the LightBurn, everything returns to normal.

When I use version 1.0.6, I can normally press the reset key to reset the control board.

So I wonder if this is caused by setting a property of the serial port after the connection of version 1.2.04.

Finally, I apologize for my impolite behavior.

In older versions of LightBurn, there was a bug with the DTR setting, and I believe it was always on, so that might be the behavior you need. You said you disabled it, but you might actually need to enable this toggle switch:

image

Thank you for your advice!

I tried to enable DTR signal, but the problem also exists(Lightburn version 1.2.04).

I also enable this option in the old version,it works normally(Lightburn 1.0.6).

Do you need me to provide some log information to troubleshoot problems?

Hello!Can you give me some more advice?

I do not know why it is not resetting. The only thing that has changed as far as I am aware is the handling of the DTR setting in LightBurn. If you have tried with it both on and off, then I’m out of ideas.