Lightburn 1.4.01says waiting for connect

Hi, I am new to this forum. I am having trouble with multiple things with Lightburn recently. I am getting “waiting for connection” and error:5 Homing cycle is not enabled in your Grbl settings. How can I fix this?

If the homing cycle is not available in your GRBL settings, then the error message is generated by an incorrect setting in Device Settings.

Click Edit, click Device Settings, turn off the Auto-home on startup switch.
It’s the top of the list of ‘Other Options’. Click OK to close the window and allow the setting change.

Waiting for Connection is a normal message to get before you connect.
You would not have gotten Error 5 unless you were connected.

Please test and verify that it’s working properly after the change to Device Settings.

Hi John thank you for your reply. I managed to get it worked out but now working on other issues. I have used this laser for 2 years with out a single issue. I recently purchased the Ortur YRR 2.0 and that’s when it all went down hill lol. I saved the default settings when setting up the YRR but when I tried to go back to the default settings I must not of saved them correctly. Now I have reset all settings to default and things just aren’t correct. When I go to start a project like I have done for years, the laser wants to go to the top right of the grid even tho my job origin is set at the home position at the bottom left. I apologize if this doesn’t make sense, its hard for me to explain. Any help would be much appreciated.

If you’ve been using the same computer for a while you may be able to use ‘Load Prefs Backup’ under File to recover settings from months ago.

If you do a brute-force-search of the hard drive for lbprefs you may find earlier Prefs files too.

Is there a customer support phone number I can call to walk me through this issue?

Most folks forget to Switch off the software part of the Rotary tool control in LightBurn and leave LightBurn in the rotary state. This is super-common so I’m tempted to ask if there’s a way to prevent it. With LightBurn open and the whole screen up look at these two locations.

If you see either of those, Open Laser Tools, select Rotary setup, turn off Enable Rotary, and click OK to change the setting.

If those aren’t there, you can skip to the next step.

There isn’t a support phone number and there aren’t plans to rescale and re-cost to make it happen.

Here’s the walk through. :slight_smile:
In LightBurn,

  • Click File
  • Click Load Prefs Backup
  • In that three months (or more) of files, pick one that’s far enough back to have been working well for you.
  • Once you select that, Click Load.

That should do it.

There was a conversation yesterday about making a short video for Load Prefs backup and the Content Manager seemed keen to make it happen.

Thank you John. I checked and both Rotary locations were off. I must have deleted the pref backups because 8/14 is all I see. Would it fix it if I just purchased a new license and re downloaded everything? I am falling behind on my work and need to catch up.


You have to go a fair bit out of your way to make this happen. It’s possible though.

Nope… in fact, I’d say it almost never resolves any problematic behavior. I look forward to the day when folks abandon this leftover Windows Vista troubleshooting technique. :slight_smile:

There’s a live set of preferences in LightBurn, every time you start it.

If you delete everything and reinstall it will pick up the old settings and you’ll be right back where you were. If the prefs are in a shared or external drive it can damage the file and cause problems.

In LightBurn, click File, then click Export Prefs Backup and save that file somewhere local, not shared and not on an external storage device.

Head over to Windows Explorer and drop down to the root of the C drive.

Type lbprefs into the search bar - then press enter - this is a brute-force search that may find some older versions of that file. This has helped a few folks out. Let me know if you find an earlier version.

in a final review before pushing Send - I reread something.

Please conduct a similar Brute-force search on your C drive for lbset files. The settings files are smaller and they may be available as well.

Let me know what you find.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.