Lightburn and CR Falcon 2 - crashes gantry

Hi All,

I just received my Creality Falcon 2 22W unit. I have set everything up, updated device firmware, installed Lightburn (OSX) and imported the machine settings.

I created my first job, homed the machine, checked the framing and everything looks great !!

I start the job the laser moves to the start of the job, then all of a sudden moves out of the job area and then rapidly moves the other way until it crashes into the side of the frame. As if there would be some kind of GCode incompatibility or something. I am using the latest version of Lightburn.

LB console shows the following

Starting stream
Stream completed in 0:00
Starting stream
Layer C03
ALARM:3
Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.
On or near line 140:

Job halted

Stream completed in 0:03

Any tips welcome. I have attached the file and generated GCode.

Thanks,
Serge

logo_badge_black.lbrn2 (183.9 KB)
logo_badge_black.gc (88.1 KB)

You’re using “User origin” as the Start From mode in Laser window. Unless you’re very familiar with the function of your laser I’d suggest using “Absolute Coords” exclusively.

Also, follow this procedure:

  1. Home your machine
  2. After homing, never move the laser head by hand. Use jogging controls exclusively.
  3. Do not ignore any warning messages

Please retest under these conditions.

Hi.

Thanks for your reply. I re-tested as you recommended but it makes no difference. With Absolute Coords I get the same result.

Thanks,
Serge

Did you follow the entirely of the procedure?

Also, can you generate new gcode with Absolute Coords set?

Hi.

I did yes … from further research it seems that it actually has to do with the Overscan setting. i.e. even though my job is small in size it seems that the gantry travels way past the job. The default setting is 2.5% but apparently this is also tied to the speed setting which I have set to 6000 mm/sec … which seems to by my error and it should be 6000 mm/min …

In any case surprised that Lightburn does not give me a warning related to the gantry maybe hitting the frame based on the location of the job on the work area + speed and overscan info it has available ? What am I missing ?

Kind thanks,
Serge

  1. Check if “Enable Out of bounds warning” is enabled in Edit->Device settings. Enable this if off.
  2. Check that your work area in Device Settings is correct
  3. Check that $130 and $131 are correct in Edit->Machine Settings
  4. Check value of $20 for soft-limits; I recommend having that enabled

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.