LightBurn bridge only sees one laser tube

I have a Supernova 10 with two laser tubes. When I connect Lightburn to lightburn bridge it does not show the options for the two lasers, however when I use USB connection it shows the options:


That is interesting… I don’t see how it would know, as far as I know the Ruida doesn’t really talk back for this kind of stuff…

Have you tried a direct Ethernet connection?

Maybe @adammhaile has a clue about this… seems to be the Pi man, so to speak…


I’m going to guess you setup 2 profiles for the same machine? One for USB and one for Bridge?
I’d wager you just didn’t turn on Laser 2 controls for the Bridge profile

If you started from scratch with the Bridge profile and know the USB one works as desired I recommend deleting the Bridge profile, then right click on the USB profile and choose “Duplicate”
Then it’ll show the device setup wizard again, change the connection type to Bridge and enter the IP. Everything else will remain the same.


Didn’t put it together with the devices profile… Thanks for hopping in and helping out …


1 Like

It helps when you have direct knowledge of the code that causes those controls to be visible or not :slight_smile:

That was just what I needed!

Thank you very much!

1 Like

Thanks for your input!

1 Like