Lightburn burning unaligned every time

Been trying to get this to burn for days now. Why does Lightburn mess up alignments every time but LaserGRBL can do it no problem? (Ignore the part that burned off the board lol. Using scrap wood and I forgot to frame it.) I’d much rather use Lightburn but it just won’t burn it correctly.

Lightburn second pic (Right side is lower and outer frame is lower). LaserGRBL first pic.

it’s hard to see what you mean by right side is lower, but the frame itself is lower I can see that. Have you tried to center the content on the frame?

What ‘Start From’ are you using? Coordinates and Job Origin - LightBurn Software Documentation

Absolute Coordinates is the simplest - The page grid you see in the main editing window represents your machine’s work area. Anything you place in that area will be cut in the corresponding place on your machine. Users with small lasers like the K40 will likely find this the simplest and most intuitive option.

Note: Using absolute positioning requires a laser with homing switches and a fixed origin. If you have a small diode laser that does not have homing sensors, you will need to manually zero the machine. See Machines without homing sensors / limit switches.

Can you post (or email) the GCode generated by LaserGRBL for the job, and the GCode generated by LightBurn? (in LB, click ‘Save GCode’ just below the Start button).

I’m wondering if LaserGRBL is using something other than G0 moves for the traversals between shapes, or if it’s just ordering the outputs differently.

The curved parts at the bottom are off.

It won’t let me upload the gcode files. What is the e-mail I should send them to?

If you name them .txt it should let you attach them. If you’re ok including the LBRN project file, that would be useful too - I can check that here. If you want to email, use and just include a link to this thread.

I have Absolute Coordinates set and I have a homing switch and home it before every frame and burn.

Here are the files
LaserGRBL.txt (52.1 KB) Lightburn.txt (45.3 KB)

Your LightBurn file is using several things that the LaserGRBL version isn’t, and those differences could be important:

  • You have LightBurn set to 80%, and LaserGRBL set to 100%
  • The feed rate in LightBurn is 200mm/min, and 300mm/min in LaserGRBL
  • You’re using the M4 command (variable power) in LightBurn, and M3 (constant power) in LaserGRBL
  • You have a start delay of 2ms set for each cut in LightBurn, and nothing in LaserGRBL

Those are possible issues, but I don’t think they’re actual problems in this case.

This is the GCode from LightBurn, run through a simulator:

And this is from LaserGRBL:

The reason LaserGRBL isn’t mis-positioning your parts vertically is that it’s running everything top to bottom and making very slow moves along the Y axis, whereas LightBurn is taking a more optimal path through the job that moves both X and Y more or less equally.

Even with a 50% faster movement speed, LaserGRBL’s GCode will take 15 min 49 sec to run, and LightBurn’s takes 12 min 3 sec.

If your Y axis speed or acceleration is set too aggressively, it’s much more likely to slip with the movement path generated by LightBurn, but you can see from the simulation that the code itself is not the problem. Lower the acceleration setting for your Y axis and I bet this misalignment goes away.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.