Lightburn camera and machine coordinates mismatch

Hello guys,

I’m having problems with matching my machine coordinates with the ones from camera. If I jog my machine everything works well, it’s returns to zero etc. But when I’m trying to make camera alignment it goes far top right almost out of my working area to engrave the test pattern. If I put a negative offset like for example G10 L2 P1 X-330.75 Y-521.25 I manage to engrave targets within my working area but then when machine tries to return to its origin I have same problem again since now its machine origine is out of my workspace.

It’s looks like my machine and camera alignment plug-in see my coordinates differently.And its not a small offset of few mm, more like 300-500 mm.

Also, when I press update overlay, I get only a small portion of what camera actualy shows in preview. Don’t think that those are connected issues but still…

I’m using lightburn camera.
no homing switch limits.
steps are well set.

Grbl 1.1f
$0=10
$1=255
$2=0
$3=3
$4=0
$5=0
$6=0
$10=0
$11=0.020
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=3
$24=25.000
$25=750.000
$26=250
$27=1.000
$30=255
$31=0
$32=1
$100=39.800
$101=40.000
$102=188.976
$110=8000.000
$111=8000.000
$112=500.000
$120=500.000
$121=500.000
$122=50.000
$130=650.000
$131=1000.000
$132=100.000

Please see here:

thank you for the reply. for my purpose it’s not as critical if time to time I had to recalibrate. For now it’s more an issue of coordinates of my machine vs camera…

It is not a question of time. LightBurn needs the machine to know exactly where it is in order for the camera and calibration to work properly.

If you do not have limit switches installed on your machine this is not possible.

I understand your point, but there are ways to repeat machine zero position without homing switches (with less precision but enough for my application).

The issue that I’m having now is that I can’t even calibrate my camera with my machine because alignment plugin sends it almost/or completely out of my working area

Turn the machine off completely, including the controller. Move the head to the front left corner. Turn the machine on, connect to LightBurn. Use the “Get Position” button. What position does it think it is at?

I understand that machine will take as 0 the start position, but nothing stops you to burn a small point with the laser at 0,0 coordinate on your working table after the calibration process and use it to retrieve your “calibrated 0” (firing at few % of power just to see the dot) in case if something wrong happens or you forgot to return your machine to 0,0 before turn in off.

observing strange connection between working size in the settings and my offset issue. With same settings if I change working size to 10x10 mm I’m staying close to my machine 0, if I change the working size to 650x650 mm the camera alignment plugin sends again the gantry almost out of my physical work surface…

There’s nothing magic about the camera alignment wizard - it generates a standard GCode job like anything else, and runs it using Absolute Coordinates (which it has to in order for the alignment to be accurate).

Can you run a job in Absolute Coordinates mode with your setup?
If you power up the machine with the laser head in the front-left position, you won’t need a workspace offset. Having one set if your origin is already correct would cause you problems.