LightBurn cannot find my LM2 laser

I am trying to get my new LM2S2 to connect to LightBurn. I’m running an old industrial computer with Win7. I’ve downloaded the Espressif CDC driver. I believe the USB cord is good, computer beeps when connected or disconnected. I’ve tried other USB ports on the computer. Other USB components (speaker, keyboard, etc.) work fine. When asking Lightburn to find my laser, it finds nothing. I’d really like to be able to use this computer, but I might resign myself to purchasing a laptop. Please help.

What does Device Manager show for the device? Also, can you confirm that a COM port is getting assigned to the device?

Device manager shows Espressif CDC listed under Ports. Also under ports are 4 communication ports that i have disabled (i believe these are the 4 DB9’s on the computer) these ports were assigned Com 1-4. I have assigned com3 to the Espressif. If i unplug the USB cable, the Espressif under ports disappears.

Try manually configuring the laser in LightBurn:

  1. GRBL (not any other variant)
  2. 390x410 (assuming this is indeed the LM2S2
  3. Front-left origin
  4. auto-home on startup

Once done, make sure that COM3 is visible in Laser window port field and try connecting.

LightBurn now shows my laser as ready on Com3 (changing Com port disconnects laser, as it should), but nothing happens. Won’t go home, won’t fire, won’t show position. Upon restarting computer, I still get the error "Device Driver software was not successfully installed: Espreessif CDC Device (Interface 0) Failed

Sounds like you haven’t installed the device driver correctly.

Take a look here for instructions:
OLM2 Pro - DRIVER WINDOWS 7.pdf (ortur.tech)

do you know if there is a difference between 2.5 (as shown in the instructions) and 2.8 (which is the most recent)?

Zadig is not the driver itself. It’s a utility that simply facilitates the recognition of the device to be served by the available usbserial driver. 2.8 or any recent version should work just as well.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.