Lightburn Device Window not showing

I have an Ender 3 V2 printer fitted with their 10-watt laser diode kit. I am running Lightburn 1.6.01. When I plug the USB cable into my computer, running Windows 10, the system beeps acknowledging the USB connection. When I start Lightburn, the Device Window does not appear. I have uninstalled and reinstalled Lightburn several times. I have tried several different USB ports on the computer and turned off power saving on the USB ports. In the Console window, it just says waiting for connection I have contacted Creality and they said their equipment does work with Lightburn. At this point, I don’t know what else to do. Any other suggestions??

Are you saying laser window not showing? If so, go to window > and make sure laser is checked.

1 Like

When I first start Lightburn, it does not show the Device Window allowing me to select the laser. This is on my desktop machine. I have tried 3 different USB ports on this machine.

**** An update ***

I have moved the setup on an old Windows 10 Laptop. When I plug in the laser, Windows beeps so I know it is being seen. When I start Lightburn on the laptop, the laser resets to the home position but the Device Window does not display. There are no tools windows on the screen to move and test the laser.

Thank you point that out!! I didn’t RTFM to discover that. The Device Window still didn’t display but I manually added the laser and now it is working properly!
I was looking all over for that but didn’t see the laser option.

Thanks again.

1 Like