LightBurn does not find my LO-E5 controller on Linux, but works fine from my Mac


First of all, LightBurn is fantastic. Together with the controller upgrade, it makes my K40 a real workhorse.

I installed LightBurn on my Mac and it works fine out of the box. But because it’s the laptop I use for my work, I’m not that keen on always taking it to the lab where I have my K40. So I invested in a second hand Lenovo X250 on which I installed ElementaryOS.

Now, the problem is that LightBurn can’t find the controller (LO-E5) on the X250. However, I see the device is present using ‘lsusb’. It advertises itself with ‘NXP’.

The ‘lsusb’ command lists the following information:
1fc9:0085 NXP Semiconductors

When I look that id up on, I find the NXP section (1fc9), but 0085 is not listed as a device.

Is there something else I need to do / configure / install?

Any help is welcome.


It’s likely a permissions issue or something needs to be updated in the udev rules. I’m not really familiar with Elementary OS - in theory it should work as it’s Ubuntu based but, for the record, we test on Ubuntu and Fedora and anything else may have issues. There’s just too many variables.
One thing I’d try first is to run as root. Assuming you installed with the .run file download, please run this:
sudo ${HOME}/.local/share/LightBurn/LightBurn
You will have to setup your device profile again unfortunately as they are per user.

If that still doesn’t work, can you please provide the output of the following commands:

uname -a
#connect your controller and then immediately run
dmesg | tail -n=100

Also, trying to connect to the device after having run lightburn from the console (using ${HOME}/.local/share/LightBurn/LightBurn) may provide debug information that will help.

1 Like


Thanks for the reply. I tested the connection running as root and that works!

Is there an example on the udev rules I need to add?


That’s gonna take some trial and error and there’s some info that I don’t have… but here’s the basics:

Put the following line in this file: /etc/udev/49-nxp.rules

SUBSYSTEMS==“usb”, KERNEL==“ttyUSB*”, ATTRS{idVendor}==“1fc9”, ATTRS{idProduct}==“0085”, MODE:=“0666”, SYMLINK+=“ttyLASER”

Note that ttyUSB is likely wrong as I don’t know what the device name in your case is… plug in your controller and then immediately run dmesg and check that log. Should have a device name in there. Then sub that in for ttyUSB
Hopefully that should be the only thing you’ll need to change.
You may need to reboot to have this take effect but you can also try running:
udevadm control --reload-rules

Here’s what worked for me:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="1fc9", ATTRS{idProduct}=="0085", SYMLINK+="ttyLASER", GROUP="johan", MODE="666"

Thanks again



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.