Lightburn doesn't control laser

On my desktop Lightburn will allow me to set origin correctly, will trace correctly, and will burn correctly. When I take the machine to the shop and use my laptop, it will not set origin by using the set origin button. When I have artwork it will sometimes trace correctly, but when I select laser start, it errors with out of range and if I select go anyway it moves the head to max on the y axis and to the far right on the x axis. It doesn’t matter where the artwork is located on the page. I checked all the settings and they are all the same on both computers.

Check these settings specifically, on both systems:

  • Machine Origin
  • Job Origin
  • Start From

I am fairly new to this, what commands are used to check machine origin, job origin, start from? I was under the impression that when you set origin it was setting the job origin, is that correct?


‘Machine Origin’ is different than ‘Job Origin’. Setting the correct Machine Origin in LightBurn is required so LightBurn knows what size bed you have and what direction from X0, Y0 to move when requested. This is set during the device profile setup and can be adjusted later as well. Click the ‘Spanner/Screwdriver’ icon near the center-top of LightBurn screen to expose.

Here is a good description of the ‘Job Origin’ and ‘Start From’ features.

I have set my bed size correctly and set the origin to front left. The problem I am having is I move the laser to some position and select job origin on the move panel. I move the laser, then select go to immediately moves toward the right front and would exceed the size if I don’t stop using the stop button. All of this is on my laptop, when I had the laser connected to my desktop in the house it works as I think it should which is set job origin, move the laser, select go to origin and it returns to the set position from set origin.

On the second machine, when you say “go to origin” it’s going to 0,0 if you’ve never set the origin on that computer. It’s just a coordinate remembered by LightBurn - it’s not stored in the machine anywhere with a GCode controller, so each computer will have its own memory of what the user origin is.

I set the size of the bed and the origin as left front. Please tell me what else (and how to do it) needs to be done to set user origin on this computer. I have even deleted and reloaded Lightburn twice.

You jog the laser to a spot and click ‘Set Origin’. That’s it.

For what it’s worth, deleting LightBurn doesn’t delete your settings, so it’s rarely a solution. (if it did, installing a new one would wipe them out too, and we don’t want that).

Through research I was able to resolve this problem. I issued a $RST=$, and a $RST=#. It appeared that these areas had somehow become corrupted. By resetting to default and clearing the work coordinates my GRBL system now works correctly.

Interesting - I didn’t know about these commands, so I’m going to have to go read up on what they do. Thanks for posting the solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.