Lightburn freeze after 2-3 min

Lightbutn freezes after 2-3 minutes with machine connected or disconnected, no matter. This happened after installation on another computer, MSI GT80 Titan, i7 6820HK, 24 Gb RAM Windows 10. Before Lightburn run well on much older computer with i5 and 8GB of RAM. Any suggestion?

Are you saying that LightBurn will stop responding to your input consistently after 2-3mins of running regardless of connection status to the laser? Are you presented with any crash report? How do you recover from this state? Please provide more details if you can. I believe this is the first report of this kind.

What version of LightBurn? Please provide the exact version number.

Lightburn version 0.9.14. Program just stops responding to input. I don’t know how to call crash report or log files. Recover using task manager.

Just checked on new Asus Pro Duo i9 9980HK 32 Gb RAM, working without problems.

Still waiting for response. Is any way I can run Lightburn on my MSI GT80 Titan?

I noted that when I upgraded to 9.14 the auto save setting was set to 2 minute intervals.

Every 2 minutes it autosaves and this caused a pause/freeze for me, some of which I could not out of.

Cancel the autosave maybe

I am not aware of any issues running LightBurn on this windows based system. You are the first to report anything like this so we am still digging. I doubt this has to do with auto-save unless you have them set very differently with one saving to network vers local storage, but even then the “freeze” would resolve after the network write completed.


Sent a PM with a link to try.

I have tried this version and also few older versions from GitHub with same results. Lightburn starts and stays stable for long time, but only until I start some input. After I start to manipulate with graphics or laser settings timer starts and I have only few minutes until Lightburn freezes. Than only task manager capable to exit program. I run Solidworks on this computer without problem, so, memory leaking is not an issue I think. After last installation of Lightburn I set autosave interval for 20 min(which is MAX) and I get slightly longer time until freeze, but less than 20 min. Frustrating.

What kinds of files are you working with? Complicated or simple? Where are you saving them? Local hard disk, network, USB drive, or cloud storage? Anything else you can tell me about when the freeze happens?

Most of the time I working with files from local hard drive. With new file open I import DXF , stored on local hard drive, then broke DXF to layers. Sometime adding simple geometry like ellipses or rectangles.
But Lightburn freezes even without DXF. Few rectangles or ellipses and lines is enough for program to freeze. May be something wrong with memory on this PC. I have to check it.

Today I have checked memory for errors for few times, no errors discovered. Behavior of Lightburn still the same, it freeze after 2-3 minutes regardless of auto save interval or laser connection.

Can you try this? In the settings, switch the ‘Camera Capture System’ to ‘Default’:


Set to Default Capture System, Lightburn ask to restart, after Lightburn restarted freeze again. Then i have to recover with task manager, restart computer. start Lightburn again, open Settings to double check is in Default Capture System mode and Lightburn freeze on Settings window.

I honestly have no idea what could possibly cause this. Are you running anti-virus software or anything that might be interfering with LightBurn saving files? A file sync utility, like OneDrive, Google Drive, DropBox, etc?

Yes I have Norton installed and driving, Windows Defender and One Drive as well

Try pausing Norton or at least granting LightBurn an exemption if that’s possible.

Lightburn added to Norton exclusion list, then Norton turned off, OneDrive turned off . Lightburn keep freeze. I’m mad.

Do this for me? Run LightBurn, go to Help > Create Support Data and paste it into a notepad file. Save that and email the file to us at support at lightburnsoftware dot com. I can’t think of a single thing that might be causing this, but I’ll look through your settings and your system info to see if anything stands out.

Lightburn Support Data.txt (4.5 KB)