Lightburn freezes 1/2 way through project

Hey guys, wondering if others are having this issue. I have been using lightburn for about two years now, but recently the system just freezes 1/2 way through a project. I have replaced the cable, but I still get the same issue. It literally says the laser is ‘busy’ and will stay that way. The counter for the project time keeps running. In the end the only way I can stop ot is shut down the program and restart. But then it happens again. Even if I disconnect the laser it still says busy and if I shut down the program a box comes up saying ‘You are currently streaming to your devce, Are you sure you want to close’? I will say, not tech savvy at all, but I have never had this problem until recently. I upgraded the software, went back to the older version I was using and the same issue has occured. To the brains trust, any advice to sort this would be appreciated. I am using an old macbook air (about 8 years old). Thank you all!

This is typically indicative of a lost connection. So then the issue is identifying what could be causing the lost connection.

Things to consider:

  1. Have you introduced any other machinery or hardware anywhere around the laser? Perhaps a device that comes on after the laser has started. Anything that could introduce electrical noise. Even a fan or furnace coming on while the laser is running could cause this. Try isolating the laser power from other devices.
  2. Has any of the software on your computer recently changed?
  3. Has the weather changed appreciably to potentially cause a higher chance of static discharge? If static is indeed the issue then this can typically be remedied by bonding and grounding the unit.
  4. Try a different USB port if available. Does your Macbook Air have USB-A ports or are you using some sort of dongle?
  5. If you’re using a USB hub have you recently added something to it or changed the port used? If so, try eliminating the hub entirely.
1 Like

Hey Berainlb, thanks so much for your reply. This is great but from your list of things to consider

  1. I have not introduced any other machinery or hardware.
  2. I have not had any software changes
  3. Hmmm, it has been very warm where I am, so I will check that
  4. I have tried both USB ports, but still have the same problem
  5. not using a USB hub.

So I will try bonding and grounding the unit and see if this works. Thank you!

Because causes for this can vary but have the same symptom disconnect you really need to be critical of your own setup to consider what might have changed.

I’ve also seen cases where the USB controller on the device goes through a partial failure where a once well functioning USB device starts working only with a very robust USB port. For example, only working on a desktop but not working on a laptop under battery power.

1 Like

That is so funny berainlb, I literally have done that now. I read articles on that and did that just now (article reference Mac USB Ports Stopped Working? It’s Likely Easy to Fix) So I will see if this helps when I get home from work!

I have had this issue recently. I was working towards the comm port solution. My computer developer brother came over and said he gets lost connections all the time with USB cables. So, we made sure the USB cable was not paralleling the power cables - still lost connection and stopped burning randomly. He then said lets try a new cable. We bought a new 6’ USB cable at Walmart and I haven’t had any issues at all since. That’s been a couple weeks ago. Just another thing to try. Best to get cables with ferrite cores integrated as to reduce interference if you have that option. Good luck!

Thanks Wilson. I have actually done that. I reset all the USB ports, bought a new cable and run power to my laptop rather than relying on the battery. I seem to be okay now, so I wasn’t sure if it was one or all three fixes that did the job, but working now! I am still concerned that I will be in the middle of a project and it will fail again, but these are things we cannot control. I do appreciate everyone’s thoughts on this. It has helped me and hopefully will help others in the future

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.