Lightburn freezes up

Running ver 9.14 ,win 10 x64, mks sbase 1.3 , smoothieware.
This is a bit hard to explain. At approx 28 seconds after starting all XY travel stops and laser is still on. Sometimes at 1 min 58 sec it will continue and then stop again forever, laser on. This part is not consistant but stopping at 28 sec happens every time. I saved the gcode and ran it in laser grbl 3.3.0 for smoothie with no problems. Similar issues occur with any file whether imported or or created in lightburn. I’m not sure what info you need or how to go about trouble shooting this issue. I’ll try to run the linux version and see what happens. Laser web seems fine also.
The board is running the latest firmware, firmware-cnc.bin. Also tried the normal firmware.bin and it froze at 43 seconds in. Laser on

Any ideas?
Thank you
config.txt (28.4 KB)
extmnt.lbrn (8.7 KB)
I tried to upload the .gc file but I guess its not allowed. I uploaded the .lbrn project file and config.txt

You can rename the gcode file to .txt and it will upload too. There is nothing in your file that suggests a reason it would freeze.

If the machine stops, but the laser itself is on, that’s not a good sign - Smoothieware doesn’t have a way that I’m aware of to make that happen, as all moves by the controller adjust the laser output power by the speed, so this suggests to me that the controller itself is freezing, but that doesn’t make sense.

LaserWeb uses ‘ping/pong’ sending, waiting for an OK for each command before sending the next, whereas LightBurn tries to keep the receive buffer of the controller full, so it’s more likely to be susceptible to communication errors if there are any problems with the hardware, noise in the connection, etc.

I think its a firmware issue not a lightburn problem .I’m going to try grbl-lpc.

OK running grbl-lpc fixed the freezing issue that it had with smoothieware but now the laser won’t fire $30 = 1000 $31= 0 $32=1 but when I set the pwr to 20% (or any value) and use the fire button I get G1F100 S .1 Which I don’t think will fire the laser. I’m sure its operator error but how to fix?
Thank you


Think I know the problem. How do I tell gbrl-lpc what the pwm pin is? I assume I have to recompile the firmware since I believe its default is arduino D11 and I need it to be mks Sbase pin 1.23
Is this correct?

There’s something in the smoothieware that is causing the freeze up. Grbl-lpc solves that. Now i have to get the arm tool chain, git, and make installed and compile new firnware so I can change the pwm pin set correctly. Should be good after that.
Thank you for your help.

Go to Edit > Device Settings and change the S-Value Max setting to 1000 to match what you have in GRBL. Smoothieware uses 1.0.

Thank you for your help. There seems to be some difference in the firmware between the normal, cnc and latest versions with the cnc giving the most problems. I’ve given up on smoothieware as it doesn’t seem to be stable at least on this mks board Sometimes it wouldn’t even connect. I’m thinking its partly a board issue with the usb.
Anyway I’m now using grbl-lpc 100% and it is much better and so far any issues have been operator error, my error. Now I just need to figure out how to get the “Make” and “Arm” tools set up so I can change a few things in the firmware like changing the default port for the laser. Lightburn seems to like it better also.

Thank you again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.