Lightburn Installation / Run Issue / Help

Recently purchased lightburn for my omtech 100w laser. I downloaded the software and ran the executable. I was able to launch the app without a problem. However, the issue i am experiencing is after i close the app and reopen. Upon reopening it becomes unresponsive and does nothing. The app will not open. I have tried uninstalling the app and have reinstalled. This will work for the first time i run the app. But the minute i close it out its done. I will no longer respond/open the app when clicking on the icon. Help Please - I dont understand what is wrong or how i can fix this.

Also, when i downloaded the application i did not see a screen to input my registration key. Should there have been a prompt?

Thank you in advance for any help offerred.

guess your computer is running Windows? Did you check the box at the end of the install process to and FTDI drivers? If not, run the installer again and make sure you install the drivers.

yep. i am running windows. I will run again and install the drivers. Thank you for your feedback.

Did this sort your issue? If so, please mark solved to help others find resolution in the future. :wink: