Lightburn is not connecting to my cnc

I’ve installed lightburn on my computer.but the software does not want to connect to my cnc (laser 5500mw) and i do not know why …
my board is grbl0.9j yet lightburn indicates the laser is disconnected. Does anyone have any idea what the problem might be or a solution.

Hi @dora, In looking at your profile, “CNC laser 5500 mw” unfortunately does not tell us much about your actual components that comprise your system. What controller are you using?

I also see that you are running “grbl0.9j” but have set GRBL in the device profile for LightBurn. If it is not the latest version of grbl (1.1f) then you should use the device in LightBurn called “GRBL-M3”. Either use GRBL-M3 Device in LB or update the firmware to GRBL 1.1f then use plain GRBL Device in LB.

Thank you for your reply.
I don’t understand every thing because it is my first cnc laser ,model:4050 cnc Laser
My controller is grbl0.9j. I also tried “GRBL-M3” but the cnc is still not ok
it does not work with grbl0.9j ?
How can i get the version “GRBL1.1f” ? do you have a link where I can get it ? How can I make it ?
Thank you for -your help.

ohh yes it’s connected!!Im happy!!


Why the laser engraving toooo slow? where is the parameter for the laser engraving speed please?

I think you might benefit from reviewing this post to help you get started.

Who is the manufacturer of this unit?

I already senn all the video today :slight_smile:

but you don’t say where? I know it’s “speed / S” but when I change this parameter … it’s always the same speed,it’s the same, always very slow…

I’m french and I do not understand English very well in your videos…sorry

this unit is manufactured in china

Double click on the entry in the cut list (the black color swatch next to ‘Fill’). That will bring up the full set of cut parameters. Having said that, you have it set for 1000 mm/sec, which is faster than my industrial CO2 laser will go, so I doubt that’s your actual problem.

Read up on GRBL configuration settings, particularly the settings about maximum travel speeds and acceleration settings here:

Your GRBL settings are likely limiting you to some horrible default, like 500 mm/min (8.3 mm/sec).

thank you for your reply. I changed some cut parameteres but it’s same,is still slow. Which parameter exactlty i must change (please the attached picture) ?
I did not find out which one in the link you sent me and the videos available on youtube.



$110 and $111 are set to 5000 mm/minute maximum speed, which means about 83mm/sec. Depending on your system. Since you have a diode laser, you likely won’t be able to get usable output much faster than that anyway, but you could probably go as high as 9000 without hurting anything.

You haven’t said what you’re trying to engrave, but if it’s a photo, that’s likely the larger problem - you’re likely using an 8-bit GRBL controller, which will have a maximum rate that it can process commands. If you’re trying to engrave grayscale or dithered images, that maximum command processing rate will be your limiting factor, not the speed setting of the controller. If you try to engrave a simple rectangle instead of an image, you should see much faster speeds.

I set $110 and $111 to 9000 but nothing has changed, it is still too slow. I m’ trying to engrave a simple text. The controller is much faster with another software called “engravermaster”, so I do not think that the speed is limitted by the hardware. are there other parameters I should try to change ?
6.30 minut for 5 little letter burn!

I have grbl0.9j,it’s a problem?

Can you post the file you’re trying to run? Without more info about what you’re working with, and what settings you’ve used, we’re flying a bit blind here.

When you say “the controller is faster” do you mean that the laser is physically moving quicker? You change that by just changing the layer speed, shown here:

Mine is in mm/sec, but yours might be mm/min, depending on your settings (most diode systems use mm/min, because they tend to be slower)

I trying just a simple text

3 mn for a little texte,it’s not nomal…
cm,mm,it’s same…it is still slow

yes the laser is physically moving quicker
I change all the parametre but it is still too slow

Image of my configuration:

I do not understand why it does not work! I am completely blocked

another question please … why is not the engraving done entirely?

Thank you for your reply …

Increase your minimum power.

You want speed, but your laser is a diode laser! if you want speed, try these

$ 110 = 10000.000
$ 111 = 10000.000
$ 112 = 1,000
$ 120 = 3200.000
$ 121 = 3200.000
$ 122 = 1,000

But when using a diode laser, you have to be slow, otherwise the results will look like the photo you sent.

If you set Lightburn / device settings / S-value max = 8000, you may get a better result. But don’t forget that fast work with a diode laser is not done.

I found the solution today! I uninstalled lightburn and everything works!now it’s very different,super!!

but there is always the problem of engraving, I change the speed, the focus of the laser, the power, always the same!

Thank you for all your answers :slight_smile:

If you haven’t upgraded the firmware in the controller (GRBL 0.9?) then you need to use the GRBL-M3 device in LightBurn, and set the S-Value Max setting in the device settings to 255 (I think - I’m not very knowledgeable on the old versions of GRBL, which is partly why we recommend 1.1f or newer, as those were what LightBurn was written to use)

yes I use grbl 0.9 but now all it’s ok , I have no problem with the speed I found the solution today :slight_smile:

juste the problem in the engraving I use the GRBL-M3 and i set the S-Value to 255, but it’s always the same problem…i don’t have this problem with another

There is a place in lightburn where you can set either millimeters per second or inches per second it all depends on which one you have set if you have inches per second and your machine is spitting out values for millimeters per second it is always going to look slow no matter what you have as a value. There is also a software out there that is free from Mad hackers that I use just for upgrading firmware on grbl. I use lightburn for all my design and cutting purposes and I use the med hacker software to upgrade firmware of driver boards. Basically the Mad hacker software is free and all you have to do is to that you’re bored to it and it will ask you if you want to upgrade to 1.1 or not if you say yes it will flash your board automatically if it’s a Arduino clone board. I hope this was a help.