Lightburn is not connecting to my laser

I’ve just installed a new cohesion 3d laserboard. The leds on the board indicate it is working properly, my laptop has identified it as a smoothie, yet lightburn indicates the laser is disconnected. Does anyone have any idea what the problem might be or a solution.

Have you selected a port? Sometimes the auto-connect doesn’t work straight away.

that was the problem. thank you very much

How do you select a port?

Down here in the Laser window, you’ll see either “(Auto)” or “(Choose)” - click that.


There is no choose, it is only auto listed.

What kind of laser do you have? If you click that drop down and see nothing it most likely means your laser is not connected to the PC, or it’s possible you need a driver, but I’d need to know what laser controller you have.

I don’t know what controller I have. The laser is a 50w Chinese model. I have been trouble shooting for days and I am unable to connect the laser. I have the trial version of lightburn and my days are running out! Any help would be appreciated!

According to Facebook you tried Whisperer and it worked? If so, that means you have an M2 Nano controller in your machine, and LightBurn does not support that controller. Whisperer is your best option unless you want to change out the controller for something else.

It is described as: model 40B mini laser CO2 engraving cutting machine, with up\down table, 50W laser, 300 x200 mm

It connected with Whisper but it was taking 3 hrs to etch a 4”x4” piece of acrylic at 200 mm. Then it was suggested to try lightburn to see if it would work. So that is why I am trying it.

Sorry, but LightBurn doesn’t talk to that controller. It could be made to do so, but it’s a large amount of effort for a controller that is very limited as to what it can do. I would look into the Cohesion3D Laser board as an relatively simple upgrade option that would allow you to use LightBurn.