Lightburn issues since last update

Since the last update (0.9.14) I have been having some issues with Lightburn. Has anyone else encountered the following…? I am running Lightburn on a Windows 10 PC.

  • Lightburn has started being a little sluggish when opening / importing files. It freezes, then says it’s not responding, and then most of the time it carries on working after a little while. It had crashed 3 times, once in the middle of a engraving job.

  • If I open a file, make some changes, and then save it Lightburn has started creating backup files. These backup files can’t be deleted unless I restart my PC. The reason being “The action can’t be completed because the file is open in COM Surrogate”. It’s clogging up my folders after a long session on Lightburn.

  • Lightburn has once again changed some settings in my coloured cut settings. For the 3rd time it has wiped out the saved name & cut settings for ‘black 00’ and wiped out the saved name for ‘blue 01’. It’s a good job I remember these settings, as they are used a lot, but it was a less used setting I’d have to go through all the test cutting again and waste material.


in settngs then file settings look for Other settings and you will see the auto save interval. if you set 0 Minutes it will turn off the auto save and stop making the files (I think) if you set it to 15 it will only save your work every 15 mins.

1 possible explination could be:-
In windows 10 there are options about using and saving folders to onedrive i.e you can set My Documents to be onedrive cloud based instead of your local pc (if you have an active ondrive cloud account) and it may be that LB is saving every 1 mins and that windows sees a new file every 1 mins and has to back it up to onedrive and this will sssssslow down like crazy even on a fiber internet connection as it needs to save, read, verify over and over as you keep LB running.

I may try setting auto save to 0 and see if it helps out, if not then,more help maybe required from a more knoledgable person than me.

Are you on the latest build of windows 10 (2004 aka May 2020 update) ?? I think there is problems with data saved in “user-name/appdata/local” folder if you do have the update you may still have the working backup files with your settings still saved in it. i.e black 00 blue 01 etc. or LB needs to update them in the latest build to fix things and make them work going forward and they need to be set back to default ??? it could be either or.


Thanks Chris, I will try the autosave as you mentioned. It never did it before, so I wonder if the defaults were changed during the update? As for the cloud, I never use it. Everything is saved to PC & hard drives.

in that case it sounds like the settings have been defaulted and I think a 2 min auto save is set. you may have turned auto save off before but it`s like magic and turned back on again. give it a try with 0 and see how it goes but remember you will need to save any changes you make to the work/design/etc after you set it to 0 off mode

This means that the file is open in the thumbnail loader that is used to show thumbnails in Windows file explorer, but this should be a very brief thing - the files are opened only long enough to make the thumbnail and then closed again. I’ll look to see if there’s a possible way they could get stuck or not close the file.

LightBurn doesn’t wipe out your cut settings - if you load a file that has different values for those layers that is what will be remembered. You can, in the latest release, set specific defaults for all layers or per-layer, and there’s a setting to tell it to restore to those when you create a new file or first run the program. It sounds like that is how you want it to work.

Yes, I have a windows 10, intel core i7 8th gen. Geforce graphics. I also have “not responding” and freezing, Had to Alt Delete. No issues with laser so far. Still think LB is a great software. Any help appreciated.

Do you see any pattern at all to when the freezes happen? Is it moments after starting the app, periodically when running it, or something else? Are you working on large files? Do you save files to a network location or a USB drive?

This has a traced image that I am vectoring pieces out of image. Running slow and when go to save “not responding”. I have done basic text on other jobs with no problems. Never had problem before with this amount on program. Thanks for help.

Mannix.lbrn (3.7 MB)

I’m beginning to suspect the framework update to be the cause of these issues. I’ve posted a version here that reverts back to the version of the framework we used on 0.9.11 and before. Can @secondwind and @Stenny71 try this version and report back if you’re still getting the ‘not responding’ issue?

Removed updated version LB, reinstall LB via link Oz provided. Repeated file I sent you and even added traces of photos and text to load up. No more freezing or “no responding” response rate is quick as before, just very slow when saving, otherwise will continue to test when I can. Thank You.
Should we uninstall LB before installing version updates?

You don’t need to uninstall the old one - the installer should install right over top. Slow when saving could be from anti-virus software, saving to a shared drive or network store, USB drive, etc. I have a change in the works to improve that as well, but it would mean files saved with the new format won’t work with older versions of LightBurn, so I want to make it optional.

I will jump back in again . Oz it seems as if it`s holding the file open . I just noticed it tonight on .14 build. My nuc i3 is a hair slower than normal but as in one of my previous replys I save to onedrive so I can design on the fast i7 “gaming rig thats never going to play games” and save to a shared folder on onedrive so the networked nuc i3 that controlls the K40 Laser and the chinese cnc mill gets direct access to the saved files without any smb networking related problems or file transfers on usb memory sticks / flash drives etc. save on one machine and the other gets a copy instantly. How networking should really work but 20 years too late . lol

Was this solved as I am getting exactly the same issues today as the original post.

All 3 of them? The first is solved, the second I’m looking at.

The first 2…

… Silly question but if you have solved the first do I need to update Lightburn to get any changes you have made to take effect.

For me Oz def network is the issue with slow and unresponsive, yesterday I copied a file to the laptop hard drive over the network to try and avoid the issue so working local, it was still slow and unresponsive particularly while panning and zooming using the middle mouse button. I disconnected the network, rebooted the machine and it was fine. Today I just used USB no network and all was fine. Hope that helps

I should mention initial zoom for example was fine. pan and zoom around about more just stops working but if you leave it long enough it catches up and so does not actually crash

Once we release these change,Yes.

This is very frustrating… it just hangs and crashes.

The previous version was stable.

I’ve checked my RAM usage when lightburn is open and it is very high.

Over 7gb of ram in use when lightburn opens a file and this drops to 2gb when lightburn is closed and the pc is just doing its normal stuff (internet etc)…

This seems like a high level of RAM for lightburn.

I have 8gb of ram so going over 7gb when opening a file is clearly causing me an issue.

Is it possible to install the earlier version (9.13) as the crashing/not responding is making it impossible to use.