Lightburn Issues

Hello everyone! I have an issue with lightburn that I cannot seem to fix. a few days ago my Sculpfun S9 would make a grinding noise whenever I am framing and would just frame incorrectly, I tried going through multiple solutions on this forum but nothing seemed to work, I cleaned my belts and also reset the software and then a new problem occured. Now the software does not frame, when framing it only goes to the area where the framed object is and just stops there, the move buttons do not work, and I am getting Error 9 and Error 22. I am not savvy when it comes to diagnostics so if there is anybody who can help, I would greatly appreciate it. here is the code from console:

Waiting for connection…

Waiting for connection…

Grbl 1.1h [‘$’ for help]

ok

[VER:1.1h.20220407:]

[OPT:V,15,128]

Target buffer size found

ok

Homing

error:5

Homing cycle is not enabled in your Grbl settings.

$0=10

$1=25

$2=0

$3=0

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=3

$24=200.000

$25=3000.000

$26=250

$27=3.000

$30=1000

$31=0

$32=0

$100=80.000

$101=80.000

$102=250.000

$110=6000.000

$111=6000.000

$112=1000.000

$120=1000.000

$121=1000.000

$122=1000.000

$130=410.000

$131=400.000

$132=200.000

ok

Starting stream

Layer C00

error:22

Feed rate has not yet been set or is undefined.

On or near line 6:

error:22

Feed rate has not yet been set or is undefined.

On or near line 6:

Stream completed in 0:00

error:22

Feed rate has not yet been set or is undefined.

ok

error:22

Feed rate has not yet been set or is undefined.

ok

ok

ok

ok

Starting stream

Layer

error:22

Feed rate has not yet been set or is undefined.

On or near line 6:

error:22

Feed rate has not yet been set or is undefined.

On or near line 6:

Job halted

Stream completed in 0:00

error:22

Feed rate has not yet been set or is undefined.

error:22

Feed rate has not yet been set or is undefined.

error:22

Feed rate has not yet been set or is undefined.

<Idle|MPos:0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>

ok

Starting stream

error:9

G-code locked out during alarm or jog state.

On or near line 4:

error:9

G-code locked out during alarm or jog state.

On or near line 4:

error:9

G-code locked out during alarm or jog state.

On or near line 4:

error:9

G-code locked out during alarm or jog state.

On or near line 4:

Stream completed in 0:00

<Idle|MPos:148.000,45.000,0.000|FS:0,0|Ov:100,100,100>

ok

Starting stream

error:9

G-code locked out during alarm or jog state.

On or near line 1:

error:9

G-code locked out during alarm or jog state.

On or near line 1:

error:9

G-code locked out during alarm or jog state.

On or near line 1:

Stream completed in 0:00

error:9

G-code locked out during alarm or jog state.

error:9

G-code locked out during alarm or jog state.

error:9

G-code locked out during alarm or jog state.

error:9

G-code locked out during alarm or jog state.

<Idle|MPos:0.000,0.000,0.000|FS:0,0>

ok

Starting stream

error:9

G-code locked out during alarm or jog state.

On or near line 4:

error:9

G-code locked out during alarm or jog state.

On or near line 4:

error:9

G-code locked out during alarm or jog state.

On or near line 4:

error:9

G-code locked out during alarm or jog state.

On or near line 4:

Stream completed in 0:00

<Idle|MPos:148.000,45.000,0.000|FS:0,0>

ok

Starting stream

error:9

G-code locked out during alarm or jog state.

On or near line 1:

error:9

G-code locked out during alarm or jog state.

On or near line 1:

error:9

G-code locked out during alarm or jog state.

On or near line 1:

Stream completed in 0:00

error:9

G-code locked out during alarm or jog state.

error:9

G-code locked out during alarm or jog state.

error:9

G-code locked out during alarm or jog state.

error:9

G-code locked out during alarm or jog state.

Here is my GCODE for the software, please help:

; LightBurn 1.1.03
; GRBL device profile, absolute coords
; Bounds: X172 Y295 to X244 Y399
G00 G17 G40 G21 G54
G90
M4
; Cut @ 6000 mm/min, 20% power
M8
G0 X172Y295
; Layer C00
G1 Y399S200F6000
G1 X244
G1 Y295
G1 X172
M9
G1 S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0
M2

The Sculpfun S9 typically doesn’t come with homing switches. If this is true in your case then don’t attempt to do an automated homing operation. Disable this in Edit->Device Settings->Auto-home on startup.

You should instead manually home the laser by positioning the laser module at front-left of machine before powering on.

After powering on, avoid moving the laser module by hand. Use the jogging controls exclusively.

Lastly, until you’re very familiar with the function of your laser I’d suggest working in “Absolute Coords” Start From mode in Laser window.

Make these adjustments and retest. What’s the new behavior?

1 Like

The gcode shows that you go at maximum speed to the absolute corner of the workspace. I would never recommend this.

Do as PY suggested, change to “current position” instead of “absolute position” and change the speed to 3000. The S9 is incapable of driving much faster than 3000 without losing precision.

1 Like

Thank you for your input, The auto home feature was deactivated as I have seen on multiple discussions that it should be off, another issue is I also get error 22 : Feed rate has not been set or is undefined

Hello, thank you for pointing that out, I have decreased the speed to 1000mm/s and I am still getting the same issue. Is it possible I may have a faulty power supply? I also have error 22 which says my feed rate is not set or defined.

Are you pushing the Home button then? Something is requesting a homing operation.

Focus on one issue at a time. Error:22 is odd since the g-code is fine. This could imply a firmware issue or possibly a communication issue with the controller.

No I am not pushing the homing button, also, I just noticed when im on the move tab, the function only works on the X axis and only when the continuous jog feature is enabled, the Y axis does nothing on both occasions…if it’s a firmware issue how do I go about solving it?

If its a controller issue does that mean the board needs a replacement?

Thank you for taking your time to help

Can you provide a screenshot of Edit->Device Settings?

Also, has Y-axis ever worked previously?


Here is the image of the device settings, yes the Y axis has worked before as I have used the laser for almost a year now, also, if I am framing something that requires to use the Y axis as well it has no problem moving, but as soon as it reaches the framing area, the Error 9 kicks in and then the machine stops. When I press frame again on the same area, it just returns to home

In LightBurn, you set the height of the workspace to 900. But in your firmware, you have it set to 400. Do you use the extension?

Edit: and you didn’t enable the laser mode, $32. Set this value to 1. Very important.

1 Like


Yes I have the extension, how do I change it in the firmware?

Also, I looked up code $32 in console and it says $32=1. What could I be doing wrong?

Have you recently changed anything either in hardware or GRBL configuration?

How are you doing this? Your first post shows $32=0.

1 Like

Yes I have been trying multiple solutions that are on similar forums, I must’ve posted this before I managed to fix that. here is my current G-Code:

Waiting for connection…

Grbl 1.1h [‘$’ for help]

ok

[VER:1.1h.20220407:]

[OPT:V,15,128]

Target buffer size found

ok

$$

$0=10

$1=25

$2=0

$3=0

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=3

$24=200.000

$25=3000.000

$26=250

$27=3.000

$30=1000

$31=0

$32=1

$100=80.000

$101=80.000

$102=250.000

$110=6000.000

$111=6000.000

$112=1000.000

$120=1000.000

$121=1000.000

$122=1000.000

$130=410.000

$131=400.000

$132=200.000

ok

I apologize for the mix up, I will edit it on the first post to avoid confusion

In first post You reset your software is the correct?

1 Like

Yes that is correct

You likely have either a failing controller or a corrupted firmware.

I’d suggest first attempting to reflash the firmware on the controller. Then reset GRBL to default values. I believe that’s safe on Sculpfun devices. Then update Y-axis max travel to 900 mm ($131=900).

Then retest.

I have tried reflash the firmware, how do I set the GRBL values to default? I have also connected on LASERGRBL and I am also getting the same errors(Locked G code) I am suspecting either a corrupt firmware or the controller issue as well. does this mean I would have to purchase another PCB Board and the issue may be resolved? this is driving me nuts it’s been 2 days running in circles, once again, I thank you for taking your time to help.

Run in Console:

$RST=*

If indeed the controller is bad then this would be the easiest route. If I recall correctly the S9 uses an 8-bit Arduino based design which could be swapped out fairly easily.

Alternatively you could take this time to upgrade to a 32-bit board either 3rd party or from Sculpfun itself. I believe they offer upgrade kits but that may only be with module upgrades.

Usually, this happens during flashing, but as already stated, $RST=* to be sure :slight_smile:

The locked thing is not really an error. If you get that, send $X and the machine is unlocked. This only happens if a situation causes a lock before.

It’s most likely no hardware issue. 99.9% sure. If, at all, it’s a firmware issue. Show a picture of your mainboard, the S9 have been sold using an 8bit board in the beginning, but are now sold with 32bit boards. But from the console output I suspect an older 8bit version. I highly recommend using the firmware provided here: Firmware Update & Settings - Diode Laser Wiki

1 Like