Lightburn Linux wont see Trocen AWC708S

Hi, Been using lightburn for a year with my little Ortur 20w laser and have now upgraded to a 100 w Trocen AWC708s. However Lightburn wont see or connect to it over USB? The old laser connects and still works but cannot get the software to see the new laser?

Im using linux based system.
I cannot download Lasercad to get a driver.

Any help would be greatly appreciated.
Cheers
Ryan

Sounds like you need to upgrade to the DSP version of LB

Hi, Thank you. I already have a license so is it an upgrade to that “normal” one?

There are 2 versions of LB, one only supports gcode controllers and the other supports both DSP and gcode, I think you now need to upgrade to the DSP version.

See here: https://lightburnsoftware.com/pages/which-version-do-i-need

Perfect will upgrade now and fingers crossed.
Thanks mate

Pleasure, I think there is an upgrade option so you don’t have to pay the full DSP price, just read it first to be sure. I reckon someone in the know will confirm if you can’t find it.

1 Like

If you deactivate the license on your Linux machine and send us the trial ID for that system we can reset the trial, so you can test first to make sure it works before you pay the money.

Now have the updated key code, but still not seeing machine?
Have updated to latest lightburn too.
Any ideas?

I have no idea if Linux knows how to talk to an AWC controller. It uses LibUSB on Windows, so that part is ok on Linux as well.

Try this:

  • Go to Help > Enable Debug Logging
  • Click ‘Devices’
  • Click ‘ok’
  • Choose the Trocen device if it isn’t chosen already
  • Count to 5
  • Turn off debug logging
  • Attach the file ‘LightBurnLog.txt’ from your Documents folder here so I can have a look.

Did you resolve this issue? I’m experiencing the same thing. LB won’t detect the laser (but Windows does!). Tried using both USB and ethernet to connect.

Resolved issue. Make sure you have the laser engraver drivers installed! Otherwise LB won’t detect it.