Lightburn losing laser connection?

I have been using Lightburn since the addition of galvo support in July of last year. After struggling with EZcrash for a year it was a godsend and made my 30 watt fiber laser a useful tool. Recently I started having issues where the laser status would switch from either Ready (If it was idle) or Busy (if it was marking) to Framing with an occasional Disconnected. If it was running when this happened it would stop marking and if it was idle it wouldn’t let me start marking a job. I had been running on the original release and declining updates because it was working so well but when this issue cropped up I did the upgrade to 1.3.01 and if anything the problem has become more frequent. Sometimes we can go for an hour or more without it happening and other times it’s every minute or two. This is running on Windows 10. If I leave device manager up it shows the laser still connected when this happens. I’ve tried 3 different usb cables and different usb ports in the computer with no effect. Oh, and sometimes when it happens switching from Auto to Port 2 in the devices section in the lower right corner will bring the status back to Ready but usually I have to either shut down and restart Lightburn, shut down and restart the laser, or both. It’s beginning to feel like EZcrash 2 all over again. Any ideas?

There’s nothing in LightBurn that should do or would want to do this.
There are tools and features in Windows 10 that mess with USB Communication.

One of the Windows 10 tools is a timer to ‘save power’ shutting off USB ports and fouling up real life controllers. The Screen-Saver and other sleep modes will hang things up so I’d look there first.

Another tool may be an anti-virus program sniffing around. Occasionally, other programs can knock a USB port out of circulation in an attempt to claim a connection.

Usually we see the USB timer issue but with the behavior at varied intervals, I’d dig into Windows settings and see what can be found.

It may be beneficial to set a timer to see if it always happens 10 or 15 minutes after the last keystroke or user input. Temporarily shutting off WiFi and Virus checking for testing may also help.

Thanks for the reply. This computer is dedicated to Lightburn and the marker. I’ve looked at the power settings and have everything set to never sleep. The timing is not consistent. We are marking two areas of each part with a total marking time of 15 seconds. Sometimes it will “freeze” on the first part, other times it will be 5 or 10 parts in before freezing. The last thing I tried was rerouting the USB cable and that seems to have made some difference so I’m wondering if the cable is picking up interference somehow.

Freeze vs. Interference; I have had this issue.

I had a cooling fan and a compressor plugged into the same outlet as my engraver. I ran a long extension cord and plugged the compressor and fan into an outlet 15 feet away. The freeze behavior stopped.

I have also read that Deep Freeze Freezers, Refrigerator compressors and A/C compressors can cause the same little power blip. Static electricity can build up with some laser diode set ups and get into the controller board through the limit switch.

Shielded USB cables with the Ferrite Choke beads are absolutely a first line of defense.

Any spinning electric motors nearby or plugged in nearby?

I hadn’t considered static electricity on a Galvo setup. Generally, what material are you working with? Is your galvo on a plastic table?

The only motor in the vicinity is the stepper for the rotary but I would think if that was the issue everyone running a rotary would be having a similar problem. Also, the freezing has happened when the rotary wasn’t running so I’m really confused. But yesterday, after a rough start, I was able to mark over 100 parts without it disconnecting although a few times I did see the status flash “Framing” for a split second before going to “busy” and marking the part. I’ve never paid this close attention to that before so I don’t know if that’s a normal thing or if I’m right on the edge of the problem. I don’t believe it’s a static issue, the Laser is mounted on a stainless steel table and we are marking bands on stainless steel tubing.

Try putting a little bit of weight (or a rubber band) on the USB plug at the computer or marker (or both). If the physical connection is at all loose (or the contacts are slightly worn) it could cause this.

Don’t overdo it - just a little pressure to make sure the connection is making good contact.

After trying all of the above suggestions including 5 different USB cables (some shielded with Ferrite chokes), moving the laser to an entirely different room, moving the computer closer to the laser and using a shorter USB cable, I was still having issues with it regularly going to Framing instead of Busy which required a restart of Lightburn and/or the laser itself. Late last week I replaced the computer, installed a fresh download of Lightburn, and so far I haven’t had any situations where it hasn’t marked a part and also haven’t had any crashes. I do occasionally see the status flash “Framing” for a split second before going to “Busy” and marking the part. Is that normal? Everything else seems to be working correctly at this point.