Lightburn / Meerk40t on Linux Mint

Hello, hope someone can help.

Is anyone using Meerk40t and Lightburn on Linux?

I have a licence that I used on a diode machine, but recently bought a K40, and I would love to be able to use Lighburn with it.
I understand Meerk40t can emulate the K40 board by using the command GRBLcontrol in Meerk40t console.

I have done that, and i do not get any error messages on the console, but even after I set up the K40 in Lightburn, is still not working.

Thanks in advance

I’m not intimately familiar but I know that the grbl related code in Meerk40t has been going through a lot of changes in recent updates.

In fact, the latest version (0.9.5 beta 2) includes this comment:
Fix grblcontrol by @jpirnay in #2499

I’d suggest trying the latest version to see if that makes a difference otherwise reaching out to the Meerk40t team to see what might be going on.

The other consideration is to make sure that you’ve setup the device correctly in LightBurn. How have you done this?

To set it up, I first clicked on devices, then Scan My Laser.
This returned the board info, but not supported, as expected, so I tried to do it manually by selecting GRBL, and doing the X & Y details manually .Not sure if this was the right selection. Might try a different one and see if that works.

Thanks for the suggestion, I will have a look.

Cheers

A critical component is to make sure that you’re configuring the connection as Ethernet/TCP with the IP as localhost (127.0.0.1) and port setup correctly, typically 23.

Hi, I have been on Github, again and tried to run the latest version of Meerk40t, but it seems that the app image is for v0.9.4020, and also the “source code.zip” is for the same version…

Do you have maybe a direct link to the 0.9.5beta2 download?

Cheers

Have you checked the releases page?

It’s possible that their tags and release versions don’t match. v0.9.4020 seems to be the correct one although I’m not super familiar with how they manage this. Based on previous releases it seems they only increment the tag version after the official release.

I’d suggest asking the devs there.

Yes, I did.
I’ve asked there as well

Yes, I did. That’s were I got the v0.9.4020
I’ve asked there about running the 0.9.5b2 Let’s see what they say :crossed_fingers:

I think an grbl upgrade board to the K40 is relatively low cost, might be a better option than fighting with the original controller through various software packages.

:smile_cat: