Lightburn not finding Omtech polar laser via HP laptop




With a polar, you don’t use the EZCad2 drivers that I know of… actually, I think they are mutually exclusive. I assume you’re USBing it over to the polar?

On the fiber you have to swap the EZCad2 for the FTDI drivers if you change from EZCad2 to Lightburn…

:smile_cat:

Ok, will try that. Someone else had said to install all the drivers. Thx!

Yes, using USB. installing just the FTDI drivers did not work either. Still unable to locate Polar via Lightburn. Any other ideas?

You need to make sure the os can see the device… this would be in the device manager for windows.

If you can’t see it there, the only place left is the driver isn’t seeing it…

Windows should make a tone when you plug in the laser… does it? If it doesn’t it still points back to a driver issue…

:smile_cat:

Hi Jack, it does make the tone when connecting USB to laptop. Thats adding to my confusion, seems like it should be discoverable.

Will try downloading Polar drivers tonight when I get home

I’m not a windows person but If it makes a noise it means it detected a device…

Can you see it in the device manager?

Have you tried to configure the device manually?

:smile_cat:

The Omtech Polar is a Ruida DSP machine, not EZCAD - so only the FTDI driver is necessary if not running a Galvo.

You may need to select ‘Create Manually’ from the devices menu, then select Ruida, USB, and run through the prompts. After that, you may also need to manually select a port. Also, please ensure no USB extensions or hubs are being used - they are known to cause problems on occasion.

No, it’s not showing in device manager and I did try to configure manually. Still shows as disconnected in the software and doesn’t show in devices.

Hi Colin, I tried both drivers on their own and together just to eliminate all possibilities. I did try to add it manually and it still shows as laser disconnected. USB isn’t being used in any other way. I tried calling Omtech tech support but apparently they leave for the day at 4.30, after when almost every working individual gets home. I have scoured the internet and help groups trying to figure this out. I honestly don’t know what else to do.

Just a thought- is there more than one USB port on the Polar? If so, do you have your computer plugged into the proper port?

Yes, more than one but they’re labeled.

Plug the usb cord directly into the Ruida… you have to have a panel open to do this. It will eliminate the short jumper usb from the case to the Ruida…


I think you are struggling with a driver issue. If the OS can’t see it, then there is little chance Lightburn will find it…

The machine makes an sound, indicating it’s seeing the usb connection, it just doesn’t seem to know what to do with it… I’d chase down and re-install the drivers.

Good luck

:smile_cat:

If it’s not showing up in Device manager there’s a deeper connection view than drivers - the Ruida controller in the Polar should show up at least as an unrecognized device under USB devices, if not a recognized one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.