Lightburn on an Openbuilds Acro 1010 settings

Ok, here is my problem. I have an Openbuilds Acro 1010 with an Endurance 10 watt laser mounted. I have the newest blackbox Ver 1.1g 2018 1112:acro1010. My lightburn is a trial 0.9.20. I have got the machine to home and move in the right direction and can manualy test fire the laser. I need all the settings to make this work. I am tired of watching generic youtube videos on how to do thin. Can someone just give me the settings or this machine that make it work. If I need to upgrase software I can do that but I just want it to work. Rick

I honestly have no idea what you mean by this. You’ve said that you can home it, jog it, and manually fire it, and then said you need all the settings to make it work, but haven’t mentioned anything yet that is a problem. What is it that isn’t working?

What I ment was I am able to get it to do that much but it wont recognize the location of the laser, when I put a design in and move the laser to the corner of my wood and hit follow it just heads back to the left front so basically I can move it manually but not by the program itself.

Ahh - that sounds like you’re just using the wrong positioning mode. Read about how the different origin settings work here: Coordinates and Job Origin - LightBurn Software Documentation

If you want the job to start from where you have the laser head, you’d use “Current Position” mode, and set the job origin point to whichever spot on the wood you had placed the laser head.

If you want to be able to repeat the job, in case you have to stop it, move the laser to that same corner, then click “Set Origin”, and use ‘User Origin’ mode when running the job.

1 Like

Ok. But another thing that is confusing is when I manually move the laser from home out to the middle the icon on the screen dosent move the same distance. Say the laser is in the middle of the machine it shows up as only 8" from the corner. I have changed the $G10 L2 P1 x y to negitive numbers that match the machine size and even different numbers to no avail. I also hait set to inch/mm in the settings.

Have you ever checked that the machine moves the correct distance when you issue a command?

For example, if you type G0 X0, then do G0 X10, does it move 10mm? If not, you’d need to calibrate the axis steps.

I homed it then put in G0 X0 and it moved just a little, I put in G0 X10 and it goes left against the left side of the machine. I put in G10 L2 P1 X-810 Y-810 hit enter and then G0 X0 and it goes left against the machine.

After homing, where is the laser head physically?

Front left.

If that’s the case, then you shouldn’t need that offset at all.

Just to check, do this:

  • Home the machine
  • Type G10 L2 P1 X0 Y0 (this will clear that offset)
  • Try the ‘Click to set position’ tool on the toolbar

image

Click around the page and double check that the laser is moving where you tell it to. If it is, you should be good to go.

Type in G10 L2 P1 X0 Y0. Machine still homes left front. Click anywhere on screen and nothing, put in G0 Xo machine goes to far right and ratchets.

There’s no magic here - LightBurn is just issuing G0 or G1 moves based on where you click, so it sounds like you have the motors wired backwards, or something like that.

Try this in the console:

G0 X-20 Y-20

If that moves 20mm into the workspace, you have a negative workspace, and likely need to move the homing location to the rear-right of the machine, where GRBL expects it to be.

So here is where I have progressed to. I was putting in G12 L2 P1 X-812 Y-812 for the machine size becaue this is a cnc with a laser. Those numbers didnt work. So I put in G12 L2 P1 X-1000 Y-1000 and when you enter G0 X0 it stays in the vorner where it should. When I enter G0 X10 it moves in the right direction but only 1/2 the distance or 5mm. When I put in G0 Y10 it only moved abot 3mm. So this tells me there is a setting off somewhere. The machine is bigger than it shoild be and it moves less than the input numbers.

Have you ever calibrated the steps per mm for each axis on the machine? Or verified that it moves the proper distance when you tell it to move a set distance? Check that - the step settings could be wrong.

I did get it calibrated, it took several tries on the x axis but everything works now. I dont remember reading about doing calibration in the online manual. I also dont remember it in a video. It might be nice to do a video on some of the hader to find settings and adjustments so it wouldnt take so much time and searching. Thanks