LightBurn possible bug in Laser mode


My settings are:
GRBL is 1.1h
GRBL in Laser Mode ($32=1).
The S-Max in LightBurn Matches $30 (which is 1000).
Power is set to 100% in LightBurn

My problem is:
When I disable laser mode ($32=0) it works as it is supposed to but when I enable it ($32= 1) it stops engraving (even though the laser turns on). So, if I increase the S-Max value to 3000 (even though it is $30=1000 in GRBL) it starts engraving again. I am having this problem only when $32=1. It seems like the pwm is somehow decreased in laser mode.

Please help me. I really love this software and don’t want to use any software.

What are you maximum travel speeds, and what speed are you asking for? If the requested speed exceeds the maximum setting for travel speed, the controller will reduce the power output accordingly so you get the ‘equivalent burn’.

Assume you asked for 100mm/sec, 100% power. If your laser was only allowed to go 10mm/sec, it would run the job at 10% power, so the burn would occur at the same level as if it had been allowed to go the requested speed.

Maximum travel speed is 1000mm/min. I have set this speed in LightBurn.

Draw a square with your speed set, and click ‘Save gcode’. It’s not magic - LightBurn just streams that gcode direct to the machine instead of to disk. If you see nothing wrong there, it’s an issue with the settings or controller.

Can you post your settings for the machine ($$ in the console) and the settings you have for the cut? I might notice something.

The issue is solved. There was a problem with my controller. I completely de-soldered the MOSFET and the two gate resistors and connected the PWM pin directly to uController. Now everything is working fine. I will definitely purchase this software after evaluating it a little more. Thanks for suggesting the supposed issue :slight_smile:

Not something I would suggest for most users, but I’m happy you’re up & running. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.