Lightburn stops responding on preview/start

I have an Ortur 20W with a 40x40cm bed. It’s a big one, yes.
I’m also trying to engrave a somewhat intricate picture (about 35x25cm).
Finally, I’m using the Offset Fill.

Put all of these things together and I get why it would take some time computing the paths either on preview mode or when actually starting the job. However, there are two things I need to say here.

  1. It shouldn’t stop responding if it’s working. We should have some kind of loading bar or at the very least not have the “stopped responding” message on the window title (althought that might be a Windows thing).
    As of now, this thing has been hanging for 30 minutes. No clue if it’s actually working or just crashed. This is a problem. Not the waiting, but the not knowing.

  2. If I try to do this project on Fill mode, it takes about 24 hours, 22 of which are just traversal moves. Solution: Offset Fill.
    That said, I found a thread on this forum where it was not recommended to use this mode on intricate designs: Lightburn not responding in preview
    However, anyone who engraves anything other than simple lines probably uses this, because the amount of traversal moves performed otherwise is just silly.
    Even on Offset Fill mode, it makes moves accross the bed that make absolutely no sense. I tried optimizing this, but without success. I don’t know the inwards of the code, but would it be too hard to simply move the head to the nearest point that hasn’t been engraved yet? Why is the machine going from x=0 to x=30cm to engrave a small dot and then coming all the way back to do another? Is there a reason to this? I’d like to understand.

Are there any options to improve this that I’m missing? All that I found so far was about using Offset Fill to improve the times by reducing the traversal moves and it works, but takes forever on big Offset Fill layers.

In sum:
Waiting say 1h for Lightburn to calculate the paths is not a problem. Not knowing if it’s doing that or just sleeping is.
Waiting 4h for the machine to engrave is not a problem. Waiting 4h for the machine to dance around the bed is.

Can you show a picture of what you’re trying to engrave?

Offset fill involves a ton of direction changes, which means constantly slowing down and speeding back up, which also wastes time.

Using “fill shapes individually” and enabling Fast Whitespace will usually give you close to the same speedup as an offset fill unless your file is “hollow” in the middle. The results will likely look better, too, since offset fill doesn’t allow overscanning, and often results in hotspots or direction change lines in the burn.

Offset Fill was never intended to be used for really complex designs, and very little effort is put into planning the path travel, aside from “inside out”.

Thank you for the reply. I’m gonna try that.
I can’t share the pic right now (I wanted to reply asap), but I’ll do it later.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.