Lightburn Ver 1.4.00

Ok, running LightBurn ver 1.4.00 with a J Tech Quad Pro 24W Laser. Controller is OpenBuilds Black Box X32.
When I try to run a job after hitting the start button the laser wants to travel to the right rear of my 1045 OpenBuilds table. On the laser tab the user origin with the nine dots is set to bottom left, on the device settings tab the origin with the 4 dots is bottom left. If I position the laser over my work piece and frame it, that works fine. Just heads back right when starting the job.
If I run the same project in Aspire using the laser module it burns fine. Someone commented on this same topic in the Louisiana Hobby Guy Facebook page and said her machine did the same thing after latest Lightburn update.
Is there a way to roll back to the precious version for testing purposes? or has anyone had the same issue, or does anyone have a fix or suggestion?
Thanks
Dave

It’s almost certainly not likely to be related to a LightBurn update but if you’d like to try it then you can install any older version by downloading from:
Releases · LightBurnSoftware/deployment (github.com)

As for your issue, how does your laser behave if you switch to Absolute Coords? Does it frame at the matching position on the workspace?

Please provide the following:

  1. Full screenshot of LightBurn with your design loaded and ready to burn
  2. Screenshot of Edit->Device Settings
  3. Run these commands in Console and return full output:
$H
$I
$$
$#
?

Ok, think I have it, on the Laser Tab, changed the start from to Current Position and all seems to be Ok,
Thanks.

If that gets you what you need then all good. But be aware that without Absolute Coords working appropriately you won’t be able to leverage all functionality in LightBurn. That may not be an issue depending on your workflow.