Lightburn will not connect to my computer

I’m running Lightburn 0.9.24 and using a Jtech 7w laser. Not sure of the firmware of the board but it is the newest available. I can not connect to my shop computer. I had Jay Johnson from Jtech try to walk me through it but he couldn’t figure it out either. He said it was a software issue. I would agree since I brought my second computer from home, connected it and the laser worked fine My shop computer is ‘older’ but still running Windows 10 with an I5 processor. I have 16bg memory and a 500gb HD. I’ve verified my com connection. LB says I am connected to COM3 and my computer verifies it. It shows up in the laser panel as ‘Ready’, it shows I am connected to COM3 and it identifies my laser as I have named it. When I type in $$ in the console panel I don’t get any populated GRBL commands as I should. It continues to say "waiting for connection’. I uninstalled the LB software and reinstalled but it did the same thing, I know the USB cable works fine because I can connect to my other computer and the software and laser work fine. I have reinstalled my laser 3 different ways (Manual, find my laser, and manual again) with the same result. Every time in the console, it says “waiting for connection”. I have checked every setting between the computer that does work and the one that does not and can not find any discrepancies. Can anyone think of any settings I may be missing that would cause this?

You may have been through some of this, but I would check:

  • Ensure you have the correct driver installed
  • Known good cabling from computer to laser control
  • Diagnose shop computer USB, to ensure it is working properly and as expected
  • Try to connect and control the laser with another software
  • Check Baud Rate setting in Device Profile
  • Check “Enable DTR” signal toggle switch is on

Start with this and provide update, we can go from there. :slight_smile:

OK, I get where you’re going with this…sort of. I installed the software (twice) and I have to assume the driver came with the software as I did not install any external software other than Lightburn 0.9.24. Where would I find the driver for the laser and what is it supposed to be? I know my cabling is good because the laser and all functions work great with my 2nd computer. I use an external USB mouse so I plugged that into another USB port and plugged the USB cable from the laser/Shapeoko into that port and nothing changed. I don’t have a second software that I could use to run the laser (Who does?) I can’t change the baud rate unless I have a connection to the laser as that setting is greyed out. What is the recommended baud rate supposed to be? On the computer that is working, it is 115,200 but I know it is different on the computer that is not working. On the one that is (now referred to as #2) working, the ‘enable DTR signal’ toggle is turned off. I’ll check to see how it is set on computer #1 (computer not working), If you suggest that it should be on with #1, why is it off on #2?

Do you have other software for using the Shapeoko, Easel or Carbide Create? This should have the driver for you motion control system. Asking if you have checked to ensure you have the correct one installed on the shop computer.

I was suggesting checking what is set in the ‘Device Profile’. This will need to be set to the appropriate rate for computer to control system communications for that computer.

1 Like

I get the same “waiting for connection” message in my console, and I’ve also checked all the cables, and it’s a Windows 10 machine.

I’ve tried the ‘order of power up’ method, by:

1: Lightburn is running
2: Laser is powered up
3: USB from Laser → Computer is plugged in

Then the ‘waiting connection’ message changes to the proper “firmware…. Blah, blah, blah… and we’re good to go.

(Most times … sometimes I need to unplug the USB, and plug it back in…. Then it seems to recognise everything).

I just recently started running into this with my Grbl-ESP32 driven Neje laser. It works with laser grbl and UGS platform, but with Lightburn I have to un/re plug the USB and it will finally connect. Funny enough, it’s only on initial connection.

Alternatively if I plug my laser in, open ugs or laser grbl, connect, then close the software and then open Lightburn, it connects fine.

It may or may not have coincided with my update from 0.9.20 to 0.9.24.

If you right click on the ‘Devices’ tab in "Laser,’ it will attempt to re-connect or connect to the selected device. :slight_smile:

So I don’t know if this pertains to @djculver 's issue or not, but it may be worth a try. Try installing 0.9.20 and see if it works. I went back and installed 0.9.20 and My ESP32 connects fine. Any later version, I tried .21-.24, all of them give the similar output…

Waiting for connection…
Waiting for connection…
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:1044
load:0x40078000,len:8896
load:0x40080400,len:5816
entry 0x400806ac
[MSG:Grbl_ESP32 Ver 1.3a Date 20210203]
[MSG:Compiled with ESP32 SDK:v3.2.3-14-gd3e562907]
[MSG:Using machine:ESP32_V4]
[MSG:Axis count 2]
[MSG:RMT Steps]
[MSG:Init Motors]
[MSG:Global stepper disable pin:GPIO(13)]
[MSG:X Axis Standard Stepper Step:GPIO(12) Dir:GPIO(26) Disable:None Limits(0.000,393.000)]
[MSG:Y Axis Standard Stepper Step:GPIO(14) Dir:GPIO(25) Disable:None Limits(0.000,815.000)]
[MSG:CoreXY Kinematics Init]
[MSG:Laser spindle on Pin:GPIO(16), Enbl:GPIO(32), Freq:5000Hz, Res:13bits Laser mode:Off]
[MSG:Client Started]
[MSG:Connecting MySSID]
[MSG:Connecting.]
[MSG:Connecting…]

When using 0.9.20 I get the correct connection…

Waiting for connection…
Waiting for connection…
ok
[VER:1.3a.20210203:]
[OPT:MPHSW]
[MSG:Using machine:ESP32_V4]
[MSG:Mode=STA:SSID=MySSID:Status=Connected:IP=192.168.1.196:MAC=7C-9E-BD-F9-D0-0C]
ok

Eveything works correctly.

Also, something else of note, in 0.9.21 - 0.9.24 while it hangs at [MSG:Connecting…], if i toggle the “Show all” switch in the console, it just keeps repeating G0 with a line feed.

[MSG:Init Motors]
[MSG:Global stepper disable pin:GPIO(13)]
[MSG:X Axis Standard Stepper Step:GPIO(12) Dir:GPIO(26) Disable:None Limits(0.000,393.000)]
[MSG:Y Axis Standard Stepper Step:GPIO(14) Dir:GPIO(25) Disable:None Limits(0.000,815.000)]
[MSG:CoreXY Kinematics Init]
[MSG:Laser spindle on Pin:GPIO(16), Enbl:GPIO(32), Freq:5000Hz, Res:13bits Laser mode:Off]
[MSG:Client Started]
[MSG:Connecting MySSID]
[MSG:Connecting.]
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0
G0

So I dunno, weird.

Well. I checked my COM port and it said the Shapeoko was connected to COM 3. I originally named my machine ‘DJShapeoko’ so something didn’t seem right. I had previously manually created 2 different machine with the same settings but did not delete them. 1 was ‘Shapeoko’ and the other was GRBL I went back and connected to the machine ‘Shapeoko’ and it connected! I went back into the settings and deleted all of the machines except for the one I knew it would connect to. I changed my GRBL settings and ran a test file. It burned perfectly!
Not sure exactly what happened but lesson learned, that’s for sure. Thank you for all of your help and for those who are still having issues, I wish you luck!

1 Like

[MSG:Grbl_ESP32 Ver 1.3a Date 20210203]

From the first group, I assume is the failure to connect.

This gives the same information you get from a successful controller connection:

[VER:1.3a.20210203:]
[MSG:Mode=STA:SSID=MySSID:Status=Connected:IP=192.168.1.196:MAC=7C-9E-BD-F9-D0-0C]

If this is from the controller, looks like it’s connecting.

Where is the “[MSG:Grbl_ESP32 Ver 1.3a Date 20210203]” coming from? Sure looks similar to both the failure and the successful connection.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.