Lightburn won't connect to laser via USB

I’ve been using Lightburn for the past couple of years with my Mantech6090 and a 13" Macbook Pro (via USB). I’m having a few issues with that Macbook so I’ve now installed Lightburn on my backup Macbook Pro which is a 15" model from 2015.

I cannot get Lightburn to connect to my laser, I hit the next button from the device wizard and it doesn’t find anything. I’ve tried it in each USB port, I’ve tried restarting with the USB already plugged in. Nothing.

I’m really not sure what to do next.

I’ve read various posts that talk about issues connecting a Ruida controller (which I think my Mantech uses) via USB but my other mac is fine, I don’t have an ethernet port on my mac (I’m not even sure if there’s one on the laser) and I really don’t fancy spending £100 on the bridge kit.

Does anyone have any ideas?

Thanks in advance

You don’t actually need a bridge if the machine is near an Ethernet connection. I gave up after about a week of fighting with a usb connection.

The Lightburn bridge has a software layer in it to deal with the Ruida UDP communications.

I ran a $12 (then) wifi bridge from t-link for a number of months before the Lightburn bridge was released. Any wifi bridge will work, assuming your wifi can reach it.

If you have a PI 3 or 4 sitting around you can download the image, write it to an SD card and run it… that costs nothing…

I suggest Ethernet as it works and doesn’t depend on changes in code to handle different types of usb devices… it eliminates the driver question.

Most of the Mac issues appear to be drivers with usb…

  1. Ethernet is better
    a. an extra pi, use the Lightburn image
    b. if you have a wifi bridge you can use that. They are pretty low cost.
  2. deal with the usb

Others have Macs and use usb, but it seems a recurring issue.

Good luck

:smile_cat:

Thanks for replying, I’m definitely going to need to research this. I do have a raspberry pi sitting around somewhere although I’m not sure what version.

Just seems crazy that USB is so flakey - I was hoping I was just missing a driver or something.

I think it runs on a 3b or just a 3 series. Mine got nailed by a thunderstorm, blew into the garage and wasted my PI 3b.

Had a PI 4 also, so that’s running the show now.

If you have one, dig it out they work great with the Lightburn image.

:smile_cat:

I do not use a Mac, but on my windows computer I have to change the port after I plug in the laser, defalts to auto and I have to change it to port 3 which will not show up until the laser is plugged in.
Good luck…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.