Lightburn won't find my LB Bridge - MacOS 12.5

I’ve gone through the setup process, bridge is showing up on my network, I can access the info page, view the logs, and can see it from the machine I am running Lightburn on, but the Bridge Discovery wizard is slow, giving me a spinning beachball for roughly 5 minutes, before telling me “No LightBurn Bridge devices” were found.

I’m unable to control the laser directly over USB because of the USB issues, I have an 8 year old MacBook I’ve been using, but I really would like to be able to use the computer I run Illustrator on.

I’ve reserved the IP address on my router to LightBurn Bridge, and LightBurn Bridge is seeing the Ruida controller. Looking at the network log it does seem to be “Running: iwgetid -r” every 20 seconds, not sure if that is expected behaviour.

Is there a way of manually adding a bridge by typing in the IP address of bridge inside Lightburn?

Any help would be welcome. I’m probably missing something obvious, but after reading through everything else about LB Bridge on the forum I am still coming up empty handed.


Did you map the address to the Pi’s mac address?

Are you ‘seeing it’ on the network/browser?

When I go through the wizard, I think I used manual and it lets me enter the IP… Just pick the device as the lightburn bridge…


Thank you very much for showing me how to manually add it. Sadly it didn’t work, once its setup manually but it doesn’t actually connect.

I can see the Bridge’s web display in my browser on this computer, and can ping it from the terminal without issue, and on the network. I’m not running a VPN or iCloud private relay or and I’ve disabled my firewall outright to get this working. I’ve rebooted my router, MacBook, and LightBurn Bridge, but still not working.
I’m wondering if macOS 12.5 broke something in how networking was setup in LightBurn maybe. I’ll try Bridge on an older Mac too see if that works next.

It works flawlessly on my old MacBook running macOS Big Sur (11.6.8). To be double sure I exported the device from LightBurn on the old Mac, copied it over to the new Mac, imported it, and it still doesn’t work there. Must be something to do with Monterey.

Can I suggest you try running a traceroute from both computers to the Bridge to confirm they’re taking the same route?

It seems most likely that this would a networking issue of some kind.

They both have the same traceroute result, though the new computers got a 17.797 ms response and the old one has a 4.773 ms response. I’ve got a mesh network, and just confirmed, LB Bridge, and both MacBooks are all connected to the same node.

Are you familiar with Wireshark or other network analysis software? Would offer a comparative view of what’s going on.

Running Wireshark now and I’m not seeing anything that pops out at me, though its a rather verbose program, and I have very limited knowledge of what I am looking for. There are a couple out-of-order tcp events between my new laptop and the bridge, but there are as well on the old laptop thats working.

Just to make sure I get everything I just reset the prefs of lightburn, tried another bridge discovery wizard run, and imported the working device from the other computer. None of that worked.

I’m gonna give up trying to get this working for now, use my old computer and get some engraving done. Thanks @berainlb and @jkwilborn for your help. Much appreciated!

If the new ‘mac’ can see it via the browser that indicates that ‘bridge’ is making through the network to both of the computers. Since the old machine can connect and function with the Ruida, that indicates the path from the network → Bridge → Ruida is functional.

The internet software is working on both machines or you would not have the browser… that leaves the new machines OS (it is an upgrade?).

I’m pretty sure Lightburn uses the standard type of i/o for an internet connection… I’m sure it hasn’t changed… Internet communications is as dependable as the software that’s been in use on it for decades…

Has Apple changed anything ?

I have two Ubuntu machines, one at the laser and use the Lightburn Bridge. I can connect them both at the same time… so it does work even with multiple machines connecting to the same Ruida. Same operation on a regular network… multiple machine could connect …

I haven’t watched it on wireshark for Lightburn, but I have watched the wifi talk. It’s also indicated on the Pi’s green wifi indicator on the board. So it does talk, probably to let the gateway/router know it still hanging around…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.