"Line" cutting issue

Hi there,

I got the Ortur Laser Master 2 S2 (OLM2-LU2-4-20W) recently.
I have been trying to engrave and cut some 2-3mm plywood and try out the machine using light burn software as a support.
I realised that when I put “line” in the software. The circle line is not perfect. (see attached)

Here is the setting for your reference.
Speed: 1600
Power: 50
Pass: 1
For both fill and line.

Here are other examples when I try to play with different speeds around 400-1600.

Any idea of how can I do to make the circle cut perfectly.
Thanks so much for the help.

That looks like it could be caused by backlash. Most likely reason for this on your laser is that the pinion on your stepper motor is loose on the shaft. Examine the pinions and make sure that you cannot wiggle them back and forth on the shaft. Make sure the grub screw that runs through the pinion is tightened against the flat portion of the shaft. There is likely a second grub screw at an angle. Make sure that one is tightened after the first one is secured.

It’s possible that there are grub screws stacked double high. In that case, first remove the top screw and secure the lower one first. You may also want to use a thread locker if you have it.

Also check the coupler that may be running beneath the X gantry that transfers motion from the Y-axis motor.

Also worth double checking your belt tension. Remove all slack so that the belts are taught but not stretched.

Hi, Thanks for replying. I follow what you said and tried to clean the belt and readjust the belt. Also to check on all the screw and make sure the X/Y axis is running smoothly. I just did a test and the result seems slightly better but also not prefect. the circle is still not round… any other idea of what is happening? Thanks.

Just to be clear, you removed the belts so that you could check the pinion on the stepper shaft correct? To make sure there was no movement of the pinion that was not directly connected to the shaft? This point is very important.

And you did this for both motors as well as the non-motor side of the Y-axis?

I stress this because this is the most likely cause of the problem on your laser.

If you have done all this try enabling “Hide backlash” in Optimization Settings of Laser window.

Does this change the output? If so, then backlash is almost certainly the problem. You really want to remove as much mechanical backlash as possible and not rely on the software workaround. If not, then possible there’s something else going on.

Ya, so far im quite confirm that i check through the X/Y axis belt and the pinion too. But I will do a detail check when i have more time.

May I check with you how to enable “Hide backlash”? is it direct from the Lightburn software?

I will try to do it last, will find a time to check re-set the machine again.


Yes. In the Laser window there is a button labelled “Optimization Settings”. Click that. Once there, there is a switch labelled “Hide backlash”. Enable that.

Thanks. Will try on it if still nit able to settle the hardware issue. Thanks

To be clear, I would consider the feature as a workaround. You really want to address the root cause if possible and you should be able to get better circles than that without the setting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.