Lines are shifted to the left vs fills

I’m using an OmTech 55W laser - brand new so just learning it’s setup.

I’m having problems with lines and fills not seeming to line up properly, despite them being perfectly centered in the software. In the example pictures, you can see how the cut out circles seems shifted to the left and slightly upward.

I made a test file and it shows similar.

In case it helps, here are my machine settings:

Any suggestions as to why and how to fix this?

If it helps I attached the test file and the machine settings file.

Machine settings - factory.55W.lbset
Fill line test.lbrn (82.0 KB)
(12.7 KB)

Did you check the beam alignment?

It seems all of the mirrors are aligned with the laser quite close to center, even at the close and far gantry positions for mirrors 2 and 3. Ramp test also showed the focal distance to be identical to the plastic tool provided (18 mm).

I’m totally new to a CO2 laser (so I’m asking to learn, not to challenge): am I wrong to think that even if the mirrors were slightly off, wouldn’t the fill and line functions still be similarly shifted (ie they’d still be in relative alignment with each other)? Or is a fill and line function a different mechanical function that can show this problem?

Here is something to try, the description is exactly the problem you described, but before you do save your default laser settings. You do this by going to edit>machine settings>save …and label it default laser settings. Hit ok. If you’ve already done that then proceed.

Next, go back to edit > Machine Settings, look in the X & Y axis settings section at the bottom, and look for the value of ‘PWM Rising Edge Valid’ on the X axis.
Change that - if’s it’s checked, un-check it, or vice versa. Then, copy the new setting over to the Y axis as well.

In the Lightburn document linked below, look for “fixing skewed engraving”


Thanks so much for the suggestion! Interestingly the ‘PWM Rising Edge Valid’ on the X axis was set to “True” and the Y was set to “False” in the factory setting (documented in screenshot above).

I changed the X to False (changed) and left the Y as False (default): the test print seems properly aligned!

I tried another burn with X=false (changed) and Y=True (changed) so this trial run has both values switched from factory. This test burn looks the same as the newly fixed trial above.

So, I’ll be doing more tests to see. I’m not sure if both the X and Y ‘PWM Rising Edge Valid’ settings are normally supposed to be the same (ie false/false or true/true).

At least with this test file, it’s not clear to me the effect of switching the Y value - perhaps I need to design some other test file? Any suggested graphic or are there any files people use for this kind of problem?

I’m relieved and thankful for the fix, @gdrennan !

Just for future notes I set both X and Y to FALSE the engravings and lines are nicely lined up. As I understand it, if the stepper motors are the same make, they should be set the same value.

1 Like

Oh my gosh! I have the same laser cutter Omtech 55watt. I got it in October 2020, so I’ve been having the same problem for a year, as I’ve been doing more and more detailed work I’d realized that certain cuts/shapes didn’t line up. I’d tried so many fixes mentioned in the official Facebook group, and also here: Slowing down cuts to a crawl, tightening the belts, loosening the belts, adding a start pause time, adding an end pause time, slowing the idle speed Slowing the idle acceleration. Nothing had fixed it. I lost literal days to trying to solve this… I was knocking my head against the wall.

That one check mark fixed it. I also had the Y PWM Rising to False and the X PWM Rising to True from the factory.
I’d seen this fix in my searches, but it was almost always suggested as a fix in relation to engraving, and I am only cutting, not engraving…

Anyway, thanks!

Wow - I’m so glad it was finally fixed! It seems they have a quality control issue!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.