Linux Y Axis descrepancy

I am using Lightburn on a detcktop running Linux connected to an Arduino UNO running GRBL 1.1h on a DIY machine. The axis is calibrated and I can send the carriage to an exact position using the consule. To test my machine I have created a 300mm dia circle (bed is 450x500) with X=0 Y=0 When I run the machine it goes well past the 300mm height way up to 490mm. I can connect my iMac to the same machine and it runs no problem.
Is there somewhere I need to set Lightburn to use Linux? I am a 76yr old noob and enjoying this challenge

It sounds like you have one set for mm and one for inches. The top of the screen will indicate mm/inches and the ‘edit → settings’ also have mm/s, mm/m and so forth.

There is another setting

  • $13 = Sets position feedback units from mm to inches. $13=1 for inches or $13=0 for mm

Since the Mac is working, it’s probably not $13 value. You can check it by typing $$ in the console, it will display these values.


Most of these machines transmit the information in ‘units’ and if the units don’t match, it doesn’t know. Both Lightburn and the machine need to talk in the same units.

:smile_cat:

I thank you for info $13 was set at 0. Changed to 1 but display still read in mm. What I cannot understand is that the coordinates on the console match the physical movement of the gantrybut the Y coordinate is approximately 50% more than the 300mm set. As an experiment I created the same circle in Open Builds and ran it which moved to the coordinates as set. I then created an svg in Inkscape and inported it into Lightburn When I ran it, it exceeded the designed settings (480mm instead of 300mm) Not sure how to resolve this other than not use Linux

First switch $13 back to 0. For lasering there’s basically no time you’d ever want to change this. This doesn’t prevent you from working in inches in LightBurn.

Let’s try an easy fix first and see if that works.

  1. On Mac go to File->Export Prefs. Save the file somewhere.
  2. Copy or transfer the file to something that you can reach on your Linux system
  3. On Linux go to File->Import prefs and load the previously exported file.

You may want to create a backup of your Linux prefs first.

See if that works. If not, then report back latest symptoms.

I had previously returned $13 to 0. Have imported preferences as described and now working as should on Linux. My only problem is to amend the display as the action buttons etc are 3X in size as to what they should be but that can be my mission for this afternoon.
Thanks very much for your help.

Go to Edit->Settings. There are sliders for toolbar size.

Thanks I got there quite easily.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.