LO E5 DSP (AWC 608 compatible) connection lost if click 'home x/y" in Lightburn

First of all, thumbs up for Lightburn software, its amazing comparing to Lasercad, although missing some functions, but I’ve read it will take some time to implement other functions.

I own a LO E5 DSP (AWC 608 compatible). Lightburn works perfect, I can cut, engrave, image engrave, but I have some trouble with the “Home X/Y” button in the Move window (bug?). The laser homes perfect, but shows “Resetting…” on the DSP and Lightburn looses connection with the DSP. I have to restart LB to get things going again. Same with the “Home” function in the Laser window.

Is this a bug? Happy to perform some tests if you would like.

“Home” on these machines is just a controller reset. It’s just how they implemented it, and their own software works the same way. (Ruida does this too)

To re-establish the connection after homing, you should be able to right-click the “Devices” button.

Yes that makes sense, I was thinking must be a bug or something, but this is normal. Thanks! :smile:

I was actually having this issue with a client, who lost connection after sending jobs. I believe (but could be mistaken) than LB comes with its own USB driver for the AWC controller. After rolling back this driver in windows device manager, and installing the LaserCAD version of the driver (Available in the LaserCAD installer) all seems fine…

May be worth trying?

Just another quick response to this: Its strange that performing a reset on the controller does not cause LaserCAD to drop the USB connection, but the connection is lost from within LB…

I wonder if the same would happen with Ethernet connection?

Are you using a Laptop? Have you disabled power saving on the USB root hub in device manager?

Thanks for the suggestion. Checked it with Lasercad today, and connection was not lost after homing, so Lasercad works fine. Could be that the developers of Lasercad build something in too re establish the connection automatically after homing (=controller reset I read from OZ’s post), something Lightburn isn’t doing.

My client is also losing connection again, so have suggested they revert back to using LaserCAD which is a shame. :frowning:

Its very frustrating to have to perform various tasks to re-connect and makes using the software very difficult. Since they are not using LB to draw, it does not really offer them anything more than LaserCAD software… Still a shame though…

The issue is the way that LightBurn connects / maintains the connection. LaserCAD re-connects each time you perform an operation with the laser, and then closes the connection. LightBurn leaves it connected.

Which controller is your client using, and how are they connected to the machine? I will try to reproduce this, but have been unable to so far. If the client is connected by USB, how long is the cable? Is their PC USB port going to sleep? This is a common issue with Windows 10.

Hi Oz, thank you for the suggestions. I have tried all of the settings within device manager for each USB device, as well as the selective power suspend within windows power management. I thought this had cured the issue, but apparently its back. I also tried rolling back the driver and using the one supplied with LaserCAD.

The connection seems to be lost after sending files, and after longer periods of inactivity. You can literally send a file, and then a moment later try to sent the same file only to get the communication error. Connection is VIA USB as the machine cannot be connected to their corporate network. USB lead is 1.5M

All of our machines utilise the Anywells (trocen) 708L or 708S. We have never had this issue with LaserCAD and have a fair few of them in use.

I’ve had others mention this before, but I’ve never been able to reproduce it. I’m going to have to see if I can find an LO-E5, because neither the 3120 or 708C I test with have ever done this, and I’m using a 6 ft USB without ferrite beads, so it’s not a great quality cable.

How large are the files you’re sending?

This is my driver info, in case it’s helpful:

Try this:

  • In LightBurn, go to Help > Enable Debug Logging
  • Send files until you get the error
  • Turn off the debug log
  • Quit
  • Zip and email me the file called LightBurnLog.txt in your documents folder

Send it to developer at lightburnsoftware dot com and I’ll have a look and see if there’s anything useful in there. I’m not sure if I’m emitting enough stats to the log to tell me much, but if not, I can add some. I’d love to figure out what’s causing this.

Thanks Oz, I will certainly perform this next time I am with them. Its strange, as the machine I have set up here rarely causes issues with connectivity.

The file sizes were very small, literally just a few small vectors were causing the issue, when I was there training their staff the basics.

I am wondering if it could perhaps be an issue with the Anywells driver not being digitally signed, in conjunction with windows security software/features?

Have you know this error to be an issue on Apple operating systems?

I use a Windows 10 PC system and a High Sierra Macbook, and haven’t had an issue on either one. You could try running LightBurn with administrator rights to see if that helps - Right-click, Run as Administrator.

I’ve ordered an LO-E5 controller to test with. It should be here in a about a week.

Thats great to hear @LightBurn , hopefully you could implement support for the Z axis on this controller as well (i believe there is even an U axis).

I can add jog buttons, but as far as I can tell there are no commands to move the Z during a cut.

One more question: was your client running more than one copy of LightBurn and jumping back & forth between them, possibly? Only the first instance of LightBurn will talk to the laser because it keeps the connection open.

Z movement doesn’t have to be during a cut (do you mean ‘z step per pass’ ?), If that’s not possible, then if its possible to implement a Z movement before and after finishing a layer to be able to start another layer with the different focus? As sometimes with some material it’s very usefull to engrave a little bit out of focus and cut the piece at the normal focus Z position.

E.g. (order by layer option on):

Layer 1 - Sort of dummy layer, does not cut or engrave or move x or y, but Z moves e.g. 1mm negative
Layer 2 - Engrave layer (out of focus as the Z bed has moved before layer starts)
Layer 3 - Dummy layer again, Z moves e.g. 1mm positive
Layer 4 - cut layer inside
Layer 5 - cut layer outside

If suchs could work, that would be very usefull.

I mean during a running job. There are no commands that I have found for the AWC that allow it to alter the Z height while a job is running. On Ruida I use the pen lift / lower commands to do it, but I haven’t found anything like that with the AWC. If you know of anything, point me at it and I’ll have a look.

Thanks for the info, I’m not a programmer (only Basic, and that was 25 years ago) , Tried to search some information about the Trocen controllers, but haven’t found any information about their commands.

However there is an auto-focus option in Lasercad v7.86.1 (in the ‘other parameters’ settings, but don’t know if that sends commands during a job and which input is monitored when selecting that option. Haven’t completed my z bed yet as I’m still waiting on some parts, so I can’t test what it does. But probably this is something what the controller does and is not controlled by software / Lasercad.