Losing Connection With Ortur when going out of bounds

I recently got a Laser Master 2 from Ortur and when I get the ALARM 2 notification it won’t allow me to reconnect the laser. I was wondering if there was some way to reset the connection from the console or something I could change so I don’t lose it in the first place. My G54 is all zero’s I have no offsets and I’m using Absolute Coordinates. I’ve run the $RST=* command and it helped because the cutter used to just read out of bounds for no reason. Now the only thing is if it happens to go out of bounds I have to restart the software. It can’t reconnect to the laser. I’ve also run the G10 L2 P1 Y0 X0 to make sure I don’t have any offsets.

Right-click the ‘Devices’ button to reset the connection to the controller.

Can you show what you’re trying to run when you get the ALARM:2 ?

I’m not necessarily running anything. Even if I manually jog to the edge it still disconnects me and I have to restart the Ortur. The console readout (from me manually going to the edge) when it happens is

Starting stream


On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]

Waiting for connection…

Waiting for connection…

Waiting for connection…

Waiting for connection…

Manually jogging to the edge will hit the limits, so yeah, that’s expected. If you use ‘Continuous Jogging’ or have $J jogging enabled in the device settings, it should check limits and prevent you from going outside them.

You can also just use the click-to-move feature, which clamps every move to be within bounds.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.